Excel Application Scope HRESULT: 0x800AC472


Recently I have problem with this error
“Read Cell Formula: Failed setting the current sheet to: . Original error message: Exception from HRESULT: 0x800AC472”

I have automation which is stretching formulas in Excel file. For some time it worked fine, but recently I am getting error above and nothing to avoid this error is working. Its not like I am getting this error everytime, sometime it is working fine, sometime not…

As many others suggested on the forum I tried:

  • to kill Excel process before stretching the formulas
  • to add delays before activities (which are causing this error)
  • copied the Excel file on the local.
  • to use workbook activities instead of excel application scope
    (nothing worked)

I did a loop which is stretching the formula and then deleted the contain of the column, sometime it worked twenty times in the row and sometimes even the first attempt caused this error.

Any more suggests which i can try to avoid this error?

Thank you!

Open Excel application inside robot machine and see if it shows any pop up. Excel would have been updated in back end.

@doceluch I guess the problem is with the sheet name. The error says

Failed setting the current sheet to: .

Are you creating any sheet ? If not, check the sheet name you are passing into the read cell activity

  • Also, if you are passing any variable as the sheet name make sure the variable contains right sheet name

  • Try manually passing the sheet name and see how it goes


thank you for you reply @ushu and @Deepan_Baskaran

There is no pop up window during the process.

But there is mistake in error message, there supposed to be variable instead of “.”. I tried to passing sheet manually already in past, but there was same result like with variable…

Hi @doceluch ,

Are theses Errors happening for Certain Cells or Even the Cell which worked at first gives out the Error Later sometime ?

Hi @supermanPunch,

These error happening for certain column (always in the different activity ‘Read range’, ‘Read cell formula’, ‘Read cell’ even the ‘Delete range’) which has formula connected to another Excel file through the OneDrive. I am aware of that this error can happened because somebody block the other Excel file,but which doesn’t make sense that robot go through for example seven tries and in next try throw the error.