Excel appears to be busy. Please check that you are not editing a value and that no dialog windows are opened

Anyone has experience with this error “Excel appears to be busy. Please check that you are not editing a value and that no dialog windows are opened.” After clicking Retry in Debug mode, the problem is solved. This error comes out frequently and inconsistently. Any help would be appreciated. Thanks!

Hi @MichaelL,

Please find the useful link.

Omkar P

Hi Reddy,

This error does not pop up anymore after adding a kill process activity before opening the excel application scope. However, now i am experiencing a new issue which is editing a shared excel file. Sometimes it works sometimes it throws an Exception from HRESULT: 0x800AC472. I have to edit the shared file instead of cloning it into a local file because multiple robots will be updating the excel file at the same time. May i know how do i solve this shared excel file editing issue? FYI, adding kill process before the excel application does not work.

Hi Reddy,

Your links don’t seem to be of any help to the difficulties I faced. Thanks for trying though.

Hi @MichaelL
Any suggestions here? I’m facing something similar, I want to append to an Excel stored in Sharepoint and the error is “Excel is not in Ready state. Please make sure you are not editing any cells and that no dialog windows are opened.”

Hi @roxana-dalia.coman ,

Have you checked if there were any excel.exe process running in the background when this error occured?

Hi, yes, I checked. This error comes when running in Orchestrator, in studio I do not have this issue.
Thanks :slight_smile:

Running the process via Orchestrator you meant? Where is this excel file located?

Hello @roxana-dalia.coman ,

Is this an Excel file which kept in local or are you using some Worksheets(like google sheets) to action?

Also you have mentioned its working with Studio and not with Orchestrator, thats a strange behaviour. So can you try to restart the machine in which you are trying to execute the process and retry the execution.

For anyone who encountered this issue esp in Excel related task. Please disable auto recover mode.