Error with using Type Into activity

Hi, hope someone can help.

I’m getting this odd error on some of my Type Into activities and i have no idea whats causing it.


I’m not sure what it could be referring to as it has a target.


and it recognises it?

Any ideas?


I think this activity was within a browser/ window scope and has been moved out?
Also you can try highlight to verify correct selector

It’s definitely picking up the selector


and its only within an IF activity thats nestled within a For Each loop.

Apart from that, there is nothing more.

and just to add, i have multiple Type Intos in this workflow and the majority of them work, only two that seem to be doing this.

Hi @JayBee,

Most activities that interact with applications will need to be inside an Attach Browser or Attach Window. Try putting one in your sequence, indicating the window you are using, and then get a new Type Into and re-indicate the element you’re interacting with.

Hi So i’ve put the activities within a attach browser and its still coming up with the same error message.

Any further thoughts anyone?


Put some delay before type into @JayBee.It might help

1 Like

I think you were right Bala.

Added 2 seconds to the DelayBefore and it picked it up.

i’ll run it a couple of more times and if its consistent i’ll mark your solution.

Thank you all.

Not sure if it helps, but change WaitForReady from “INTERACTIVE” to “COMPLETE”

Yeah, tried the DelayBefore a few more times, it hasn’t worked. Matt_s, i’ll try your method now.

Thank you.

Update - still no further with it.

Keeps saying i need a target or run it with in a attach browser. tried all but still not working.

I’m at a lost at the moment.