Error while invoking UIRobot.exe from command prompt

i am getting the below error while invoking UIRobot.exe from command prompt.
Logon failure: unknown user name or bad password.
The command i am using is:

“C:\Program Files (x86)\UiPath Platform\UiRobot.exe” /file:“C:\Users\user1\Documents\UiPath\zoro1\c123.xaml” /input:"{‘arg1’:‘hello’}"

@nagakula
did you tried with this following path:
C:\Users<userName>\AppData\Local\UiPath\app-2017.1.63\UiStudio.exe
please check … this path will work from Run command as well as from command prompt.

Hope my inputs are useful.

i tried this and command executed successfully.
But nothing comes up as in the robot is not doing the actions or activities mentioned in the xaml.
But i could see UIRobot.exe process running in task manager.

did you login into OR ( https://platform.uipath.com ) and configured your business case with machine ?
if not please configure.

I am running in my local machine where i have developed the xaml file.
Could you please help me understand why do we need to configure it in OR as i am just trying it in my local machine.

oh ok … it’s my mistake… You have to create your script in your local and publish it from the Setup tab.
next open UiRobot.exe and it will start visible in System tray.
click on that icon and click on settings. you will find following dialog.
image

when you open this icon you will be able to view the status as follows:
image

hope my inputs are useful

Hi! What kind of activities are in your workflow? Maybe this guide will help with the arguments:

Also, i’ve tested different types of workflows(UiAutomation, excel…) and the robot runs and i can see executing the activities(without being connected to orchestrator)

its just the ping monitor.xaml available in the path “C:\Program Files (x86)\UiPath Platform\Library\Samples”.

I tried several options to run from command prompt but it simple gives me the below error. I am running 2017.1 now.

There must be some simple access issue which i am trying to figure out but no luck till now :slight_smile:

Hey, were you able to solve the issue?

Hello !

I was able to resolve this issue by actually navigating to the current version of studio being used. For example -

Incorrect :: \AppData\Local\UiPath

Correct :: \AppData\Local\UiPath\app-19.10.1

Hence the UiRobot kept at this path “\AppData\Local\UiPath\app-19.10.1” will execute your .nupkg file.

Hi to all,

Does anyone have an updated version, because today, my AppData folder of UiPath looks like this:

I cannot run my process from there, and when I try running it from PS, I get something like

the business case is the following:
Our Oracle-based ERP has an automatic scheduler for running different tasks ( creating invoices, orders, validation, etc.)

My process is sometimes running exactly when the ERP scheduler is running, thus creating some anomalies in the system.
Scheduling at certain times is not a 100% solution as both processes (RPA and ERP) are dependent on their workload.
One solution would be to invoke PowerShell at the end of the ERP Scheduler that will trigger my RPA process. When the RPA Process ends, it should use some PowerShell script to trigger the ERP scheduler.

This would create a loop, it would solve the workload dependency and eliminate anomalies.

Can anyone support me with something like that, from a technical point of view?
I have no experience in coding with PowerShell.

Thank you in advance!