Error while inserting data to MS Access

I am trying to insert data from excel to MS Access table. But I keep getting this error. I get the same error when I tried with Execute Query activity as well. Could someone please let me know what I am missing? Please note that the space in column names cannot be avoided.

Execute Non Query: The Microsoft Access database engine cannot find the input table or query ‘DT’. Make sure it exists and that its name is spelled correctly.

Source excel:
image

Insert query in Execute Non Query:
“INSERT INTO [TestTable] ( FName,Place,[Start DT])
SELECT FName,Place,[Start DT] FROM DT”

I just started getting the same error this week on an automation that had been working perfectly for months.

If you have your data in a datatable and want to write it to an external database, use the Bulk Insert activity.

You’re trying to do “from DT” thinking it pulls the data from your DT datatable variable, but it doesn’t. Access doesn’t know about your datatable variable. It’s trying to pull the data from a table named DT *within the Access database * - and since no such table exists it’s erroring out.

Hello,

Did you resolve this issue. I have the same since end February time to time.

A script running since more than 3 years with the same ms-access database suddenly throw this error with a select query.