Error when creating pivot table

Hello everyone. I urgently need some help. I have created a sequence where my bot manipulates a excel sheet and is then supposed to create a pivot table in a new sheet with that data. Whenever it gets to the create pivot table activity, it gives me this error message “Create Pivot Table: Unable to set the SaveData property of the PivotTable class”. Has anyone had this issue before. I can’t find anything online about how to fix it.

PivotTable.xaml (13.7 KB) (10.9 KB)

@Hi Juan_Pablo_Mantica,

Might it would be helpful for you. kindly review

Hello @raja.arslankhan . Thank you for that. I believe this might be a useful solution. I’m still having issues with the normal excel activities because at some point in the process my excel application freezes. Has this happened to you? What I am doing is getting an excel sheet, deleting rows that I don’t need, sorting the data, creating a color range for the values in a given column, and then I want to create a pivot table using you code. For some reason it freezes half way through.

hELLO @Juan_Pablo_Mantica

Please check whether the range for creating the pivot is properly provided. Maybe the below video can help you to create a sample pivot table.

@Juan_Pablo_Mantica let me check in advance version. I will inform you. At this time I am outside

Hello, did you happen to get the chance to see this? My issue is that the excel application freezes. It lets me navigate within the application, so I can go to the file tab, or the home tab etc. But for some reason, it does not let me change any of the values, save the file, or even close the window. This is where my sequence runs into the error.

@Juan_Pablo_Mantica Yeah I faced this issue in client’s machine. I solved this issue by killing all excel process before performing any action

Do you mean that you killed all excel process at the beggining of the sequence? Or before every single activity? And how do you kill all excel process?

Used kill process activity before opening excel file. In kill process activity give “excel” as a process name.

Still no luck. The application still freezes out on me. Any other suggestions?

I have a recording of the process but I still can’t upload attachments to the forum.

1 Like

can you perform manual operations on excel or not. which version are you using?

I have Excel version 2108. I am able to perform manual operations until a certain point. I am unsure what goes wrong. Any chance I could share this video/screenshots with you somehow? please share here

I think currently you are using excel scope application activity.

Yes, I am. Please take a look at the email I just sent you. Thank you!

yeah I have been received your email and I am looking it. please give me little bit time.
I will email you in any query.

I think excel is creating issue during file saving and closing excel. am I right?

Yes. For some reason, right after all the click activities to perform the conditional formatting on the cells, I am completely unable to do anything with the excel file. I have no idea why this happens.

can you give me file and code. if you have no privacy issue. I want to run my end. Thanks