Error trying to import package into Orchestrator - invalid package details

This is an official UiPath package (UiPath.Terminal.Activities.2.3.0.nupkg) and we cannot upload it into Orchestrator.

image

Hi @postwick,

You could try checking if you already have the same library (with the same version) in one of your projects as dependencies? If yes, the library would already have been uploaded to the Orchestrator.

I am assuming this error is probably to avoid duplication of existing version of the package. Similar to when we publish packages, the package version cannot be the same as the one already existing in the Orchestrator.

The libraries don’t upload to Orchestrator for us when publishing with a project, we have to upload them manually. This is due to security/firewall configuration.

This package version does not already exist in Orchestrator.

image

Also, we get the same error in two Orchestrator systems.

was there any orchestrator upgrade or studio upgrade with the previous versions of packages?

No upgrades

From your screenshot, i see that the library is been uploaded 1 hour ago with 2.1.0 version. and you are uploading 2.3.0… was there any chances where someone created the 2.3.0 versions already and deleted it? did you tried to upload with different package versions? if not, was there a major changes from 2.1.0 to 2.3.0 (better to compare the packages and changes in it)

These are official UiPath packages. I don’t know what changed between versions. We are updating Orchestrator to keep it up-to-date.

Hi again,

I did search in the documentation to know more about this specific error code but the reason is poorly documented by UiPath.

I also don’t think the changes to the library itself will cause this error.

https://docs.uipath.com/orchestrator/reference/response-codes
image

Hi Paul,

Have you manage to upload the package? I have a similar issue with the Office 365 package.

Regards.

HI @CristianZachiteanu,

It seems that packages that use .net5 version are only deployable on Orchestrator 20.10.6 and later.

Can you check your orchestrator version and .net version of the package you are trying to deploy?

REgards
Sonali

It’s been a long time since I posted this, I don’t even remember where it got left. Been using the 2.1 version of terminal activities and it works great except for the Terminal Session continue on error bug.

HI @postwick,

Are you able to upload package to orchestrator now succesfully?

REgards
Sonali

No it still doesn’t work with the v2.3 terminal activities library.

Can you provide details on your installation that could help to narrow down the issue?

  • Orchestrator version?
  • Cloud or On-prem?
  • Versions of Orchestrator prereqs
  • etc.

I’ve tested in my sandbox which current has Orchestrator 20.10.8 and was able to upload UiPath.Terminal.Activities 2.3.0 to both a Tenant Feed and Host Feed without issue. The Host Feed had a pre-existing 2.0.1.

If you have a private installation, it would be helpful to know if the logs in Event View reveal further information about the error.

As @sonaliaggarwal47 mentioned, .NET5.0 TFM was added in 20.10.6, looking at the dependencies of UiPath.Terminal.Activities 2.3.0, Microsoft.Xaml.Behaviors.Wpf > 1.1.19 targets net5.0-windows7.0 and I imagine it is attempting to grab the latest 1.1.37 perhaps. my Orchestrator installation has 1.0.1.

If you are indeed running Orchestrator < 20.10.6 and cannot upgrade, check your version of Microsoft.Xaml.Behaviors.Wpf if you don’t have 1.1.19, try uploading that specific version which targets .NETFramework 4.5.

v2020.10.4
On prem
Don’t have info on all the prerequisites for the terminal services activity

An upgrade is a major undertaking given our highly regulated environment, and we won’t be moving to 2020.10.6 any time soon.

Hi @postwick,

Incompatibility between Orchestrator version 20.10.4 and .net5 version looks like an issue here to me.

Any possibility to upgrade orchestrator version? If not, I think previous versions of this terminal activities package only can be used with 20.10.4 version of orchestrator.

Regards
Sonali

No, we can’t upgrade.

And why would UiPath release a package that only works for a version that doesn’t exist? 2020.10.6 didn’t exist when we started having this issue.

check your version of Microsoft.Xaml.Behaviors.Wpf if you don’t have 1.1.19, try uploading that first then UiPath.Terminal.Activities 2.3.0

At the moment we are speculating based on the information we have, you would need to gather Event Logs when the error occurs to see if more information is revealed as well I try the suggestion above

Microsoft.Xaml.Behaviors.Wpf 1.1.19 was released Jan 2020 and still using .NET Framework 4.5, 1.1.31 moved to .NET5.0 and released Jan 2021 and the package dependencies of UiPath.Terminal.Activities is looking for Microsoft.Xaml.Behaviors.Wpf (>= 1.1.19).

Manually uploaded Microsoft.Xaml.Behaviors v1.1.19 into Orchestrator. The upload of UiPath.Terminal.Activities v2.3.0 still failed.

Where would the log files be, that would show more info about the error?