Error trying to import package into Orchestrator - invalid package details

This is an official UiPath package (UiPath.Terminal.Activities.2.3.0.nupkg) and we cannot upload it into Orchestrator.

image

Hi @postwick,

You could try checking if you already have the same library (with the same version) in one of your projects as dependencies? If yes, the library would already have been uploaded to the Orchestrator.

I am assuming this error is probably to avoid duplication of existing version of the package. Similar to when we publish packages, the package version cannot be the same as the one already existing in the Orchestrator.

The libraries don’t upload to Orchestrator for us when publishing with a project, we have to upload them manually. This is due to security/firewall configuration.

This package version does not already exist in Orchestrator.

image

Also, we get the same error in two Orchestrator systems.

was there any orchestrator upgrade or studio upgrade with the previous versions of packages?

No upgrades

From your screenshot, i see that the library is been uploaded 1 hour ago with 2.1.0 version. and you are uploading 2.3.0… was there any chances where someone created the 2.3.0 versions already and deleted it? did you tried to upload with different package versions? if not, was there a major changes from 2.1.0 to 2.3.0 (better to compare the packages and changes in it)

These are official UiPath packages. I don’t know what changed between versions. We are updating Orchestrator to keep it up-to-date.

Hi again,

I did search in the documentation to know more about this specific error code but the reason is poorly documented by UiPath.

I also don’t think the changes to the library itself will cause this error.

https://docs.uipath.com/orchestrator/reference/response-codes
image