Upload package NOT WORKING after Orchestrator update on 27 Nov 2019!


I noticed that after the update that happened less than 24 hours ago I am no longer able to upload packages to the cloud orchestrator. From the web interface, I’m getting “An error has occurred” with no additional details. The same through the API. I’ve tried deleting the package also and renaming it. I’ve also tried to upload an older version which I know worked before. And I’ve tried on multiple platform.uipath.com accounts. But always getting the same error.

Is this a general issue?


No. If the machine is connected to orchestrator, it will publish the package for sure, Can you try reconnecting the machine and studio and check

The publishing from the Studio works. I’m talking about manual uploading of other packages using the web interface i.e. going to Management → Packages and click the “Upload” (arrow up) icon. Or through the “/odata/Processes/UiPath.Server.Configuration.OData.UploadPackage” endpoint.
I need this to upload a package with custom activities we’ve developed.

Here’s a short screen recording:

I’m getting the same error. Not sure about the issue :slight_smile:

1 Like

@HareeshMR any way we can report this to the technical support at UiPath? I believe this is a core issue. For example it means you can’t deploy a new version of a workflow if you have custom activities that were also published through the orchestrator as packages (and not from a separate nuget feed, or copied manually). Thanks!

UPDATE: managed to get hold of someone at UiPath. The upload now fails if it’s a library rather than a workflow. In the Enterprise edition there is a separate section for uploading libraries which is not yet active for the community edition. I’m waiting now for a suggested workaround to publish a library (with custom activities in our case) on the community edition.

Any anwer from uipath. I have the same problem

Hey, sorry for the late reply. In order to upload libraries you have to activate “per Tenant” libraries.
Go to “Settings → Deployment” and in the bottom half, in the “Libraries” section click “Tenant”. By default it is set to “Host”. Voila. You should now be able to upload library packages. But also make sure you upload them in the right section i.e. go to “Packages” and then, in the top menu, click “Libraries”. Hope this helps.