Error: "Task was canceled" while connecting robot and orchastrator

Hi guys, I am having this problem and I couldn’t solve on my own nor reading threads about this subject. Please any one can help me.

It all happened after my client changed some policies on their VM. After being able to connect to their VM using a VPN this error started to occur, i’ve tried some solution like restarting the service and creating another robot but none of these solutions helped me.


Hi @Gabriel_melo

I think the robot is failing to connect to the orchestrator after the policies are changed.

Check whether your VM has a visible connection to the orchestrator machine

Check whether the required ports to connect to orchestrator are open

Also make sure you guys have access to the internet in these machines


Hi @Gabriel_melo

Does this help?

1 Like

Hey guys, Thank you for your help. It was a firewall problem. To be honest I don’t know what changed since it was my client that solved the problem but it was something related to the firwall. So if anyone has this same problem as me in the future check the firewall and the connection.

1 Like