Error saving as a file with Excel

Hi there.
I have a problem saving as in Excel
1.- I download a “.CSV” from a website.
2.- I open it and click Save as.
3.- I select the file type and write the new name.
4.- When pressing save, it does not save it with the new name, it always leaves me with the extension .csv or the old name.
In the image you can see it.

The file gives problems to transform it in other ways that I have tried with uipath, due to its structure, but when opening in excel it correctly opens the csv, so I need to save it.
any ideas?
If necessary I upload the activity

Hi @Aguirre

Can you please try with below method.

Step1: Use Read CSV activity to get Data from CSV file into Data table.
Step2: Use Write range activity to write data table data into Excel file.


Hello, as I have commented on this I have tried and it fails, it is because of the type of file.
The “Importe”(amount) column does not recognize me
09/09/2021 09:39:28 => [Debug] Depuración iniciada para el archivo: CSV_Test
09/09/2021 09:39:30 => [Debug] CSV_Test Executing
09/09/2021 09:39:30 => [Debug] Excel_Test Executing
09/09/2021 09:39:30 => [Debug] Read CSV Executing
09/09/2021 09:39:30 => [Debug] Read CSV Closed
09/09/2021 09:39:30 => [Debug] For Each Row Executing
09/09/2021 09:39:30 => [Debug] Body Executing
09/09/2021 09:39:30 => [Debug] Add To Collection Faulted
09/09/2021 09:39:30 => [Error] Add To Collection: La columna ‘Importe’ no pertenece a la tabla DataTable.

I show you how it opens according to format