Error of InsertDataTable activity

I test the InsertDataTable function, but fail.

1.READ data from an Excel file. Pass
2.WRITE data to another Excel file. Pass! it shows the read and write activity setting is correct.
3.Insert data to Oracle data base, it shows the error:
Insert: Object reference not set to an instance of an object.


What’s the problem? How to solve it?
Many thanks!

Hi Rale , welcome to the Uipath community forum
There could be multiple reasons for it

  1. Is the datatable in the DB having same number of columns as with the Datatable from which you are passing the data ?
    2)Table name correct ? mismatching with upper/lower cases/ spaces at trials
  2. In the variable pane of datatable “dtTest” at the default value give as “”


1.I have checked the table structure, it is the same between RPA_CASELIST and savedate_test.xlsx .
Table name is all the upper cases char.
2.I show an complier error when I set the variable default value to “”. Would it be some mistaken for this expression?

Hi , there is a typo mistake
It’s new

1 Like

can i have a view on the property panel of INSERT activity with a screenshot if possible

Cheers @Rale

“new” works well.
Thank your great support!

BTW, I think it’s not reasonable to set the default value. It may be a bug for INSERT function.


After adding a default value of “new” to variable, the problem was solved .

Hi , Because sometimes the tool might not recognize the Datatable , so we just need to initiate it by giving default value as New

Please mark the topic as solved , so that other users with the same issue can refer to it

Happy Automation

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.