Error in Http GET Request in UiPath

Hi all,

Using UiPath, we are trying to get the credentials from Hashicorp Vault using the Http Request Activity. Here, we are facing one error while performing the Http GET Request. When we pass the client_token in a variable in the headers section of the request, it gives me an error - “{“errors”:[“1 error occurred:\n\t* could not find version data\n\n”]}\n”.

image

When we try to execute the same request using Postman the request executes successfully.

On further troubleshooting we identified the issue is arising due to a trailing forward slash in the URL Endpoint in the Http Request Activity :

Although the Endpoint is maintained correctly as “https://vault.colpal.cloud/v1/secret/data/teams/iam/rfc-ids/APT%20to%20LM7”, can we remove the mentioned trailing slash?

Referred this note on UiPath Forum - Link (Did not work)

It would be great if someone could help.

Thanks,
Deepa Tharwani

@BP_Deepa_Tharwani

Welcome to forums

For the post man I think there was encoding for %20

but Can you try giving the space instead of %20 in the endpoint and try?

Thanks

Hi,

I tried replacing the %20 with space in my URL endpoint but it gives the same error - “{“errors”:[“1 error occurred:\n\t* could not find version data\n\n”]}\n”.

The issue is arising because of the forward slash in the end as seen in the Preview URL field.

@BP_Deepa_Tharwani
Try below workarounds

  1. ContinueOnError property = True

  2. Preview URL - A preview of the URL provided in the End Point field, taking into account the information provided in the Parameters section.

Check the Parameter section for any extra “/” or any Space.

Hi Karuna,

  1. Even after changing the ContinueOnError parameter to True, it gives the same error - could not find version data.
  2. The Parameters field is completely empty with no “/” or spaces.