ERROR HRESULT: 0x800700c1. open java application

Hi, I’m starting a new development and I can’t open the java application. I am using: Use Application/Browser.
But when I try to open it, it tells me:

Exception from HRESULT: 0x800700c1

I have tried “start process”. It gives me the ok but the application does not open.

If I do it manually it works and detects the buttons correctly.
I look in the task manager and I don’t see anything running.
Any ideas?

1 Like

Hi there,

Open the application Manually and then use “Open Application” - Classic or “Use Application/Browser” - Modern activity and indicate the opened application. In the properties panel->Selector replace dynamic values if any with wild card Asterisk - *.



Did you install JAVA Extension?

And also in start process you have to give the executable of the java application something like jp2launcher.exe

You can get the correct exe by checking task manager when you open the application manually. Giving jar does not work…it is not an executable or the process start

And using application browser you can try starting by setting these values


In the Start process first one is for Exe file and second one is where you need to pass if any application input parameters are needed


Hi @Aguirre
The error code **0x800700c1** indicates that there is an issue with the application you are trying to open using UiPath. This error is typically caused by a missing file or a problem with the application’s configuration. To resolve this issue, you may need to reinstall the application or check its configuration settings to ensure that everything is set up correctly.

when selecting the activity it gives me the java path, not the path of my file, which is:

I put this as an argument?

When opening the application, I only get that open java, nothing else:

But if that were the case, the application would not work manually either, right?

My selector:



Try passing the jar file as argument …

So Normally you can open application by using a file or you go to web and once you click it gives you a file and you have to click on it to open

Which one are you following for the application?



Use Application: TRA : No open windows were found for “java.exe”. Check if the app is working.

I have seen that a Java window was opened and it disappeared.


If I directly press the .Jar manually, the application opens, if no more windows.
Now following these steps, I see a .java window open and disappear, and I get the error:
Use Application: TRA Version: No open windows found for “java.exe”. Check if the app is working.


Try these 3

In Start process

  1. Give the jar file directly in the first field
    2.Give Java.Exe in the first field and jar fiel in the second
  2. Give the java.exe in first field and use another start process and give .jar in the first field

Ideally when you open the jar file is only Java.exe active in the task manager? or you have something else also that is running?

any jre or anything else?


Once you Indicate the application window, Go to selector field and open it in UiExplorer. At the top go to Options, instead of Default try with “Ui Automation (UA)” or “Active Accessibility (AA)” frameworks.

Hi @Aguirre , use java -jar <name>.jar syntax.
When you double click the jar file manually, the system knows to pick up the java executable from the Path variable (it is associating the extension type with the file just as docx files are associated with Word).

Hi, I managed to open it by double clicking on the file, but I would like something cleaner.
I have tried to create a .bat and run it, but it doesn’t work either, I am going to try these ideas that you give me.

Thanks, it didn’t work for me.

Sorry, it’s not clear to me. I give you my data and could you give me a screenshot, indicating how to put them?
“C:\Program Files (x86)\Java\jre1.8.0_261\bin\java.exe”

Person, using start a process or open an application? and in argument?


Generally 1 and 3 work for me depending on the kind of java application.

But just to be sure gave 2 as well


C:\Program Files (x86)\Java\jre1.8.0_261\bin\java.exe -jar C:\TRA\TRA.jar

Java is the process name
-jar <file>.jar are the arguments

Therefore use
C:\Program Files (x86)\Java\jre1.8.0_261\bin\java.exe on the first line of StartProcess activity
-jar C:\TRA\TRA.jar on the arguments line of StartProcess activity

Hello option 2, it is the only one that does something, but it gives me an error that does not clarify anything, since that path is not from the app, nor from the java folder.

Captura de pantalla 2022-12-16 a las 9.40.36