Error getting Storage Account from Azure (using Azure Activities Package)

I am trying to get a storage account from an Azure Resource Group. I am getting the error below.

Get Storage Account: An error has occurred. Please check the logs Error: Could not load type ‘Microsoft.Azure.Management.Storage.Fluent.Models.SkuName’ from assembly ‘UiPath.Azure, Version=, Culture=neutral, PublicKeyToken=null’ due to value type mismatch.

Here is the properties

And the xaml layout

It is running through the ‘Get Resource Group’ without issue and correctly assigning variable. It then throws up on the ‘Get Storage Account’

Any thoughts? Thanks for the help!

Hi @Tanya_Kannon,
Just to be clear here. Have you defined Azure Scope accordingly to documentation?

And secondly inside Get Storage Account you need to provide Storage Account name as a string type. I guess otherwise you should have error here but just wanted to be sure :slight_smile:

I have filled out the details on Scope (and am able to retrieve the resource group so I know they are correct.) I have also put the name of the storage account in the requested box.

Never hurts to ask😋

Tanya Kannon

Centric Consulting

Sorry for late reply. I contacted with our team about this issue. Could you try to test this on previous (1.3) version of the package? :slight_smile:

I tried it with both 1.1.3 and 1.1.2 and got the same error for both (with the adjustment in the version).

No worries about the timing! Thanks for your help!

Hi Tanya,

For this type of error you should have a matching error in the Eventviewer logs > Applications Section from the source UiPath.

Could you please replicate the error and copy the full stack so we can investigate this further?

Many thanks!

Please check that the feed is enabled in your package sources and try again.
Can you please also share your Studio version?

it is enabled! I am using studio version 2020.10.0-beta.1008

I have located the Event Viewer but I am not finding any errors from UIPath in it. I can share the xaml file (not posting it to the forum but privately) if that would help instead?

The error seems to be pointing to a dependency issue.
Can you check you can resolve all the dependencies of the actual pack like below by going to the Project Pane and expanding the Dependencies?
The culprit seems to be the Microsoft.Azure.Management.Fluent one

I am not sure what I would see if there is an issue. I have expanded all and scrolled through the entire package and nothing seemed to be flagged as different.

Here is a picture of my current manage packages

That shows you can reach the packages from the UiPath feed. There may be others that are dependencies of dependencies. If you open Studio and go to the Project pane (1), Search for the ItAutomation Package (2) and expand it you should see the dependencies of the pack (3)

I did that and ended up with this list

What do I need to do now?

Hi @Tanya_Kannon,
Post our call this week, I tried to replicate the issue. But I am not getting any error. Could you please share your workflow with us? You can zip the folder and send to

Just sent it!

Hello @Tanya_Kannon, could you please delete the highlighted dependencies from the project and try running it.

That worked!!!

Can I ask why that worked?

Hello @Tanya_Kannon ,
I created the similar workflow locally and then compared with the one provided by you. I found that the highlighted dependencies are duplicated in your workflow, the one at root level and the other under UiPath.Azure.Activities.

Looks they are conflicting at runtime. So removing the one other than UiPath.Azure.Activities helped.