Error for UiPath Apps: The UiPath Assistant is Required to Complete this action

Any time I click on “Preview” in the Apps Designer, it starts the app. The momment I hit on a button designed in my app >> it triggers an attended process > at this momment it throws this error.

Can not detect UiPath assistant. However, I have UiPath assistant installed on my computer and its connected.

Try this:

  1. Open Task Manager->Details tab and confirm “UiPath.RobotJS.UserHost.exe“ process is running. If it is running, right-click and select End Task.

  1. To restart the same process, open “Task Scheduler” and select “UiPath RobotJS“ task. Click Run on the right side pane.

If the above didn’t help, perform a new clean reinstallation of the UiPath Studio/Assistant/Robot and check the results.

You may use any of these installers:

Thank you, good amount of information. Mean while I had tried a restart of the laptop and it worked! However, I would like to know what is causing UiPath apps to throw the error notification. Why it is failing to detect while the cloud orchestrator does recognize it and it’s connected?

I think the UiPath.RobotJS.UserHost.exe process was Stopped. After the restart, it was Started again.