Error " Could Not Connect To UiPath Robot Service. Make Sure The Service Is Started"

How to ensure connection to UiPath Robot Service?

Error Message:

Resolution: From the error snapshot, it is evident the Robot service is running. The following approaches can be attempted,

Approach #1:

  1. Restart the service manually and check if possible to Run it back:
  2. Go to: Run-> type services.msc->UiPath Robot-> Right click and start
  3. If the options Stop & Restart is not visible, open services in admin mode.


Approach #2:
Generally, this issue can be caused by incorrect permissions. The following steps can be attempted to troubleshoot the issue.

  1. Go to Start > Run > and type regedit
  2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. Right click on the control folder and go to Permissions. The permission for control panel will open
  4. Select the user with using which it has been logged in and "Allow him full control". If the user is not added then add the user and give full control to the user
  5. Kindly reboot the system post changes are applied.

‚Äč


In case necessary permissions are not available, then local IT team needs to be approached to update the configuration changes.

Approach #3:
If still facing the issue after applying the above changes then

  1. Check if some policy is enabled, if yes, disable the proxy and try again.
  2. Check with IT team if something is restricting UiRobot.exe service like antivirus, or some organization policy.