Error - Anchor based selectors are not supported in Selector Editor

Hi All, I am facing an issue while using an anchor based activity to extract specific field data from a pdf file. To use Get Text on the right side inside anchor based activity. It’s showing a popup that Anchor based selectors are not supported in Selector Editor. Could you help to how to resolve this issue.

@balkishan - Please check the below post. I hope this will help in addressing the issue you are facing.

Nothing is giving in this @sreenivasm ?

For anchor base, selectors can not be edited in edit window. Copy the same in UiExporer, fine tune the selector and then replace it.

@balkishan - Looks like this is the expected behavior. Another post related to this.

Hi, Can you more elaborate it. I am not able to find the proper solution. Even using GET OCR Text activity showing the same popup window.

In anchor base activity we could not select or add selector editor.
The adjustment finds element activity automatically get selector of an anchor element.
In anchor base activity.


Yes, I agree with you but when we capturing particular item in a pdf file. It is selected accurately but while displaying or storing data into a variable it’s found null, means no data. When observing in selector it’s showing the popup with “Anchor based selector are not supported in selector editor”.

Hi @balkishan

This is actually an expected behaviour. You are not supposed to edit the selector in this window because it is supposed to find it by itself based on your defined anchor.

There might be another issue that causes the text to not be properly fetched.

Hi @loginerror, Thanks so much for your kind reply. As I have used many different pdf file I can understand if there is an issue with one pdf. At least it should work for one pdf but it doesn’t work for none of the pdf file same popup I’ve been facing. Still the issue is not resolved.

What version of the Adobe Reader are you using? There are known issues with the DC 2019 version and we suggest you use the 2018 one:


I have uninstalled the DC 2019 and installed DC 2018. Same issue I’m getting after installed the DC 2018 version of Acrobat Reader and captured the element. When I see in the selector area it’s written that “Anchor based selector are not supported in selector editor”.


@loginerror Please see Adobe Acrobat Reader DC 2018 is installed on my system. But still I am facing the same issue. While using the GET Text, Get OCR Text and Get Google OCR Text Activity inside the right side of Anchor Based Activity. Please see the attached images.

I am also facing same error. i AM USING COMMUNITY Edition of Uipath and DC 19 version and see same error that Anchor based selector are not supported in Selector Editor. I checked the video training where it ask to open Selector for GetText (under Anchor based) which shows exact text. - YouTube

Please share the solution if you have

Hi @Ajeet_Pratap_Singh

Welcome to our UiPath Forum! :slight_smile:

This is the expected behaviour. It will automatically detect a piece of the the element selector that it should look for based on the specified anchor. This is why it is not possible to directly edit it anymore.


i am trying to put type into activity into anchor base but its not going to attach in anchor base activity.

anchor based selectors are not supported in selector editor