Error after las windows update

Hello,

i have this error in the log, when i run the robot in studio this get a frezze or something and the then robot not continue, and dont show me a error, just this error in log

10:27:13.1389 => [ERROR] [UiPath.Studio.exe] [7] $LoadAssembly: Microsoft.Exchange.WebServices.Auth, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35: System.IO.FileNotFoundException: No se puede cargar el archivo o ensamblado ‘Microsoft.IdentityModel, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ ni una de sus dependencias. El sistema no puede encontrar el archivo especificado.
File name: ‘Microsoft.IdentityModel, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’
at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Reflection.RuntimePropertyInfo.get_Signature()
at System.Reflection.RuntimePropertyInfo.get_PropertyType()

Hi @rodrigoneira,
Please try to reinstall Studio based on this post:

nop,

10:52:29.3033 => [ERROR] [UiPath.Studio.exe] [19] $LoadAssembly: Microsoft.Exchange.WebServices.Auth, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35: System.IO.FileNotFoundException: No se puede cargar el archivo o ensamblado ‘Microsoft.IdentityModel, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ ni una de sus dependencias. El sistema no puede encontrar el archivo especificado.
File name: ‘Microsoft.IdentityModel, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’
at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Reflection.RuntimePropertyInfo.get_Signature()
at System.Reflection.RuntimePropertyInfo.get_PropertyType()

Hi @rodrigoneira,

I think the issue is with “Microsoft.IdentityModel”. Can you try updating that software?

Search for “Windows Identity Foundation Pack” in Google and download it and try again.

ok, is fixed that problems

  • windows feature - check indentitymodel

but now i have another problem

11:38:00.6063 => [INFO] [UiPath.Studio.exe] [1] System.NotSupportedException: Not supported xaml format, fall back to designer.Load()
at UiPath.Studio.Plugin.Workflow.WorkflowHandling.DesignerBuilder.LoadFileInDesigner(String fileName, WorkflowDesigner designer)
11:38:01.7123 => [WARN] [UiPath.Studio.exe] [1] XamlMigration: removed reference System.Runtime.WindowsRuntime

Hello, Can you try this?
Open xaml in notepad or in any text application and search CurrentIndex="{x:Null}" delete this element it will appear two times than save the file and open xaml it will work. This solution was made by indra.

now: [UiPath.Studio.exe] [1] System.IO.IOException: Cannot locate resource

ok, I think something is not being found. Do you have any activities with the blue warning? Also, try updating your packages. Go to Packages and update all packages in your project dependencies.

image

with blue warning I mean the below icon:
image

image

that vertions its ok,

see that now

15:25:41.3357 => [INFO] [UiPath.Studio.exe] [1] System.NotSupportedException: Not supported xaml format, fall back to designer.Load()
at UiPath.Studio.Plugin.Workflow.WorkflowHandling.DesignerBuilder.LoadFileInDesigner(String fileName, WorkflowDesigner designer)
15:25:41.5541 => [WARN] [UiPath.Studio.exe] [1] XamlMigration: removed reference System.Runtime.WindowsRuntime

If you create a new project and run it, do you receive the same error? Or is it only in this project?

all project,

i thing that problem is relationated whit invoke workflow activity (maybe)