Error after converting file to Windows from Windows Legacy

Hi,
After converting the code from Windows Legacy to Windows I am getting error.
Read Range: Could not load file or assembly ‘DocumentFormat.OpenXml, Version=2.7.2.0, Culture=neutral, PublicKeyToken=8fb06cb64d019a17’. The system cannot find the file specified.
Due to this the working windows legacy code is not working after conversion.
Can anyone suggest the approach to make it working?
Thanks in advance!!

in such a case we would check the version of the UiPath.Excel.Activities package and do tests by upgrading / downgrading it

Hi @Kunal_Jain ,
Have you check version of Excel activity package
Have you check this link

HI @Nguyen_Van_Luong1
I have checked and upgraded it to latest version.
Thanks!!

does it mean, that it is working now? If so, the topic could be closed by:
Forum FAQ - How to mark a post as a solution - News / Tutorials - UiPath Community Forum

No It is not working now also.

then tell us details, if further assistance is needed

Hi @ppr
image
This are the activities I am using but getting the same error.
Please let me know in case of any changes I can make to make it work.
Thanks!!

had you ever tried to model a separate a simple flow in a new project, directly set to Windows compatibility. We worked last week on some RnDs and read range from O365 was working.

Feel free to share with us your XAML result (the failling one, after the Legacy-To-Windows conversion). So can we can do some other checks

Actually I cannot share the workflow or XAML.
But you can suggest me what should I try.
Thanks!!

expand and show us please:
grafik

check in the folder:
%userprofile%.nuget\packages\documentformat.openxml

which versions are present

Hi @ppr
image
Please find the attached screenshot.

we assume that your shared details are showing that one from the Mail activities, but not the package we asked for.

As already mentioned:

when upgrading Office365 package to 2.2.7 was not helping then try stepwise downgrading it. Depending on the level of UiPath.SystemActivities maybe some other level harmonizations could be explored.