Entry point is not set as expected in the package

when I publish a project on Orchestrator even if I have the Main.xaml set as entry point it happens that another workflow was automatically set as entry point.

It happens with different project a lot of time, but sometimes it also happens that the project is published with the correct entry point (without changing anything).

How can I resolve it?

I’m using the 2022.10.4 studio version

Hello @valerio.boffino

Please confirm whether you have set multiple entry points in the project.( Right click on the xaml and Enable entry point).

If that is the case then while creating the Process, you can set the entry point.


here the screenshots about what I was meaning.

In the Project screenshots you can see that only the Main.xaml is set as entry point and in the last screenshot you can see that I’m not able to change the entry point when I’m adding the process (there is only a radom xaml file that i can choose like entry point)

P.S… I’m using the Enterprise version

Can you try Make a camp as entry point by right click on an camp and publish the package to orchestrate.

Check whether that new entry point is visible while creating the process.


I’ve just tried and it doesn’t work, i can only choose the one that is in the screenshot above :roll_eyes:

Not sure what can be the issue. What I can suggest is to create a new project and copy the xaml files to that new project. Hope it can solve your issue.

Don’t make the changes to the project.json file or other dependencies. Just copy the required folders and xamp files


I have the same issue with others project, so I don’t think that it could be helpful.

I think i will try to install another version of the Studio

Thank you

I’ve just uninstalled that version of UiPath Studio and installed a previous one; now it works correctly.

I think it could be a bug of the new version :innocent:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.