"End of expression expected" error in HTTP Request Wizard

I am trying to get data from payload, in order to achieve this I need to provide request payload link. While giving that link I am getting the below error. Could anyone suggest the solution.

Strings have to be in double quotes

Basically, it is not a string. Even if I give it in string I couldn’t able to get response from payload.

It is a string. It literally says “EndPoint (String)”

This activity is for consuming the API of an external application. What are you trying to do here, it looks like you’re trying to just browse to a web page. That’s not what this activity is for. Or you’re not using the correct endpoint URL for the api. The page=2 part jumps out to me as not correct.

I am trying to do a POC to print payload data into excel. As part of that I am trying to invoke existing payload from HTTP.

we would handle the page parameter as below:

resulting to:

But we would not mix up HTTP Request and navigate to for our work as indicated by Paul

Thanks Peter,
I exactly gave the filed inputs as mentioned in above screenshot. At last when I click on preview I am getting the below error.

You will need to find out from the API end what it expects. Is there any documentation available, maybe a Swagger interface for the API?

It is the sample api present in google. I took it from “https://reqres.in/” just for testing purpose


Have you tried unchecking the SSL box? Setting AcceptFormat to JSON?

Tried that way, but no luck

Try it without https:// or with http://

Tried that way too paul, again facing same error

FYI you don’t put the Endpoint in double quotes in the wizard.

You just type it into the wizard:


The wizard puts it into double quotes in the property:


Tried the way you mentioned. No luck yet :worried:

As both of our screenshots a looking same, but you are getting the error message, let us clear the details:

  • UiPath.Version and Edition
  • UiPath.WebApi.Activties Version
  • used TargetFramework (Windows, Windows-Legacy)