Empty Orchestrator API Versions


I am trying to setup Robot to Orchestrator. When in uipath robot tray I enter the Machine key and Orchestrator URL and click on connect I get an error : Empty Orchestrator API Versions!

NOTE : I created my account on Orchestrator around 6 months back. Not sure if it has something to do with the error.

Can someone please help.

1 Like


Welcome to the UIpath Community.

Now orchestrator was moved to Cloud and API also changed and now no need to use tenant name. Could you please login into this site either of the login option and check it once whether Robot status available or not.



I am having the same issue regarding “Empty orchestrator api version”. Can you be more specific with your reply? UiPath Robot is asking for: Machine Name, Orchestrator URL and Machine Key. Thanks!

I figured it out via another post. The Orchestrator URL is not the URL for your specific instance of Orch. It’s the overarching "https://cloud.uipath.com/


I am facing same issue like “Empty Orchestrator API Versions!”.

After reading this post I have changed orchestrator URL to “https://cloud.uipath.com/” but still it gives same error - “Empty Orchestrator API Versions!”.

Thanks In Advance: :slight_smile:

1 Like

I have solved this issue finally.

I have tried with Orchestrator Url as “https://cloud.uipath.com/”. It works for me.

como lo solucionaste???

Orchestrator url must be full url with tenant and service name, not just tenant.


kindly share the solution

I have changed url to “https://cloud.uipath.com/”. It works fine. Currently I am using this only.

Please changed url to “https://cloud.uipath.com/”. It works fine for me.

1 Like

First I was getting “Empty Orchestrator API Versions” error. After reading this post I changed the path to https://cloud.uipath.com and now I am getting “Invalid machine key” error message.

I am getting the machine key from orchestrator/management/machines/[machinename] and clicking on edit.

I am using Community edition - Studio 2019.10.0-beta252

How to resolve? thanks in advance

Solved the issue using this post Not able to connect with the orchrestrator


Please share solution for the error"invalid API version"

Am also facing the same issue after changing orchestrator url to https://cloud.uipath.com please help on the issue

Could you please let me know how to you solve that error. I’m also getting same error

I found the solution for the issue faced as u all faced

The issue is while setting Orch. url in the uirobot.
We need to write the whole service address as does not mapp automatically

In My case as eg: https://cloud.uipath.com/sayanbhan/UI_test_TAGIC/ has to be written instead of https://cloud.uipath.com/sayanbhan in Orch url.

Also NOTE: the new url has got changed to cloud instead of platform.


Thank you it’s helped, uipath url/servicename/tenantkey

1 Like

Unexpected character encountered while parsing value: <. Path ‘’, line 0, position 0.