Dynamic selector not working - test file/Oracle form

Hello. I am trying to understand the dynamic selector. I followed the research through to this link.

I attempted to download the xaml/json file and see if it worked for me which it did not. I am trying to use dyanmic selectors with variables assigned earlier in the project to select the correct box on the screen. The first image is of the downloaded project file in the documentation. The second is of my example.


Welcome to the forum

ensure for the stand alone validation

  • a variable POToUpload of datatype String or Int32
  • variable has a default value, which will work for a validation
1 Like


Both were ensured. POToUpload is a String and I tried an Int32 to see if it worked that way.

Can you explain further on the second? How would it be dynamic if it were a default value?
POToUpload is assigned a value earlier in the project (a six digit number). Before I change the selector, they are similar. For example,

Purchase Orders…) - 688888

POToUpload is assigned 688888 earlier in the project.

1 Like


Ah! That was the solution! Thank you for that. I assigned a value in the variable before the project started and it validated it. Thank you!

1 Like

when the bot is running it will take dynamicly during the run the variable value and use it
when you validate in the selector editor / UiExplorer the selector the variable doesn’t have a value. Thats why the default value is needed

1 Like

Perfect, just do your final testing and close the topic with marking the solving post as solution. So others can benefit from this. Thanks

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.