Download file activity picking .tmp file issue

Please Help me if anyone knows or has the solution to this issue.

@ali.mohammed You can try to set a filter on the download file. For example only download *.zip files that would exclude the .tmp file

@jvanmarion The download file activity doesn’t have any filter to apply

Can you tell me what you do exactly? Because that download file activity will download the file from a url into a local folder. It’s not doing anything else.

So i think your question is in the next part. What do you do next when you have downloaded the file?

Hi @ali.mohammed`,
Did you find out ?
I have the same issue …

I am currently using delay activities inside the download file activity by adjusting the time it takes to download the file.

Im also using DownloadFile activity and have the same issue with .tmp file…
Doesn’t matter if you downloading .zip .doc .docx or other file. I always get .tmp
Using this .xaml →
How does the "Wait for Download" activity work? - #2 by ptrobot
Somebody know how to fix this?

Try 10 sec delay at the end inside download activity. If download activity is still getting a .tmp file, try increasing the delay time. See example below:

Let me know if that helped.

It doesn’t work

Could you please try to increase the timeout property and see if that helps?

Also, please try checking out the latest available System activity package, just to be sure.

1 Like

The default 300 sec for timeout is a lot of time for a file to be downloaded. My files usually get downloaded in 10-15 sec. So, I don’t think increasing the timeout property would change anything.
But still would try that. Moreover, the latest package is also experiencing this error.

Hi @ali.mohammed

Could you share:

  • exact version of your web browser
  • exact version of your System activity package
  • (optional) a sample project that reproduces the issue for you, preferably using a public website

That will help us investigate the issue further.

@loginerror I believe that this is happening because Chrome first creates a .tmp file and only rename it to a .crdownload file when the actual downloading starts. In between, Chrome is checking if the download link is pointing to a malicious file. This check is usually very fast so it’s not a problem for most people. But if there’s a delay between the renaming from .tmp to .crdownload, the Wait For Download might think that the .tmp file is the downloaded file.

image

That might be, I will add it to our internal ticket.

I know that the activity is already programmed to handle the .tmp files, but it could be that some corner cases still need to be adjusted.

Thanks!

3 Likes

In the meantime, here’s a workaround using Do While:
WaitForDownloadSkipTmp.xaml (13.7 KB)

1 Like

Thank you @loginerror for working on this fix.
Thank you @ptrobot for the workaround workflow for this issue.

1 Like

Waiting for this fix

2 Likes

I got same error while downloading Zip file , it showed cannot find file at “downloadpath\somename.tmp”

4 Likes

I’m currently facing this issue, I tried the workaround mentioned above but that did not work for me as the file name never changes from *.TMP! Please someone help

Hi @Ali_AF

This might not be a full proof workaround, but if you can extract the URL of the file you want to download, you may try the HTTP Request from the WebAPI activity package to download it by making a GET request and saving your file via the ResourcePath property:
image