Bot getting stuck at Downloading File in FTP server


I have a bot that needs to download a bunch of files from an FTP server that would take about 2.5 hrs to finish. (files are txt files so should not take long to download one file)

My problem is that my bot gets stuck randomly at times but it is only getting stuck at the FTP Download activity. I tried using Timeout Scope and Wait for Download activities but to no avail. Most of the time, Wait for Download activity retries the download process after 1min of no progress. But sometimes 5+ min has passed but the bot is just stuck at “Downloading: file” Log. I even added a delay before downloading the file but it still didn’t fix my problem. It sometimes works if I restart the process but I don’t want to rely on manually restarting the process every time I encounter this problem.

Thank you!

Hi @tdg1102,
I face similar issues with other activities. Often it helps to use a retry scope around the bugging activity with an interval of 5 seconds.


Thank you for the tip! I will try to use retry scope as you said. Will post updates.

Hi @tdg1102 If the issue still persists, another way would be

  • Use while loop, within that use Path Exists activity to check the downloaded file and it returns True or False
  • Loop continues if the Path Exists activity returns False
1 Like

Will also try this. Thank you!

Hello! I tried your solution for 3 days and it worked fine when I was testing it on my local machine. However, when I uploaded the process and ran it on production, it happened again, it got stuck on the downloading part of the process. Any idea on why this is happening?

Hello! Sorry, but I have no idea how to solve it in that case.

If it works locally but not on the server I would guess it has to do something with the firewall or setup that might slow down the request / data transfer and hence time out.

Hello! Sorry for the late reply but I also tried this. My problem at the moment is when BOT tries to download an ftp file, it just gets stuck there. I even added log messages before and after the download activity to make sure if that activity really is the cause. And yes, the FTP Download activity is the only one that gets stuck. It’s not throwing timeout errors and retry scope didn’t work as well. It only gets stuck when I run it on orchestrator on production machine. It works perfectly fine if I run it in my local studio.

Update: I think I’ve solved the problem by using a Lan cable for production. We were just using Wifi before but when I used a Lan cable, it didn’t get stuck anymore. I think it has something to do with ftp connection with Wifi or something I’m not entirely sure but since changing to this, the bot doesn’t get stuck anymore.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.