Doubt on project 4

in project 4
in the output box i’m getting error as
“Cannot communicate with the browser, please check the UiPath extension.”
how to rectify this

@Kumari_Richa_A Welcome to UiPath Community

Install the Required Extention

Click on Home then Tools then UiPath Extension, select the app and install it. .

checked in tools, its installed already
still showing the same error

this output error is shown in project 4

UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension. —> System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x80040234 at UiPath.UiSystemClass.StartBrowser(String bstrSelector, String bstrURL, String bstrArguments, UiBrowserName browserType, Int32 timeoutMs, UiBrowserFlags browserFlags)
at UiPath.Core.Browser.Open(String url, CommMethod startBrowserMechanism, Boolean privateSession, Boolean headlessSession, Boolean defaultSession, String cmdLineArgs, Int32 timeoutMs)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.ObsoleteAsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Have you installed your UiPath extension to the particular web browser.


The error message you provided indicates an issue with communicating with the browser while using UiPath. The error suggests checking the UiPath extension, as it may be causing the problem. Here are a few steps you can follow to troubleshoot this issue:

  1. Ensure that the UiPath extension is installed and enabled in the browser you are using (e.g., Chrome, Firefox). Go to the browser’s extensions or add-ons menu and verify if the UiPath extension is present and activated. If it’s not installed, you can download and install it from the UiPath website.

  2. If the UiPath extension is already installed and enabled, try disabling and re-enabling it. Sometimes, extensions can become unstable or encounter conflicts, and a simple disable/enable process can resolve the issue.

  3. Check for any updates to the UiPath extension. Make sure you have the latest version installed. UiPath periodically releases updates to address bugs and compatibility issues.

  4. Restart both the browser and the UiPath Studio or Robot. Sometimes, a fresh start can resolve any temporary communication problems.

  5. If the issue persists, try using a different browser. For example, if you were using Chrome, switch to Firefox or another supported browser and see if the problem persists. This can help determine if the issue is specific to a particular browser.

  6. Review the UiPath documentation and community forums for any known issues related to the browser or extension you are using. Other users may have encountered similar problems and found solutions or workarounds.

  7. If none of the above steps resolve the issue, consider reaching out to UiPath support or their community forums for further assistance. Provide them with the error message and any relevant details about your environment, such as the UiPath version, browser version, and operating system.

Remember to consult the official UiPath documentation and resources for the most up-to-date and accurate information on troubleshooting this specific error.

Hi @Kumari_Richa_A - welcome to UiPath Community

Please go to your browser and see if the extensions is enabled.
For example in Chome:

  1. Navigate to chome://extensions and there check if the UiPath extension enabled

Please suggest what browser you’re using?

it showed same error while performing the project so i clicked on extension enabled from chrome://extensions and from there enabled extensions

extensions are enabled
i am using chrome

Can you please try performing a machine restart and post that try again. At the times the Robot runtime is unable to communicate with the browser and then see if works as expected. Thanks

still same issue

Is it possible to update chrome to the latest version?

Also can you try automating any other browser enabling and installing extensions, is it a similar issue or its just Chrome?
Just try automating Google Homepage in MS Edge


Can you Share error screenshot here

i am using windows 11 only
after completing the project
i clicked on debug file
after entering all the input data it redirected to microsoft edge where the link is open
there after entering values when i open the ui path after a minute it shows that “cannot communicate with browser error”

please share chrome extension screenshot as well.

Please navigate to edge://extensions/ and then enable UiPath extension in there

Please confirm that which browser your using?