Directory path does not work in orchestrator

My program was running fine when I start it from the studio. The directory path and folders are created neatly. However, when I tried starting the job from Orchestrator, the folder paths goes wrong, causing the program to fault. Part of my path are from the Asset, and the another half part are defined in the studio. Does anyone knows the reason?

When running from studio it takes the inherited file path from the main file of the root folder.

When running from orchestrator - you are normally required to provide the Full file path of the file you are trying to invoke.

If you can provide an example, I can try help you more.

The path I store in asset is e.g. “C:\folder\folder\folder” . When calling in the program, I wanted to add a folder and copy all files inside this folder. So in it, I have assigned a string "now.toString(“yyMMdd”) + "_" + var + "_" + now.toString(“hhmm”) +"\" . var is a id which will be given. All is good in studio, where files will be in the folder as created above e.g. “200715_VAR_0930”. But when in orchestrator, it creates a folder of yyMMdd first and a sub folder of var + “_” + now.toString(“hhmm”). Somehow the first underscore had become a \ ?

@TyraS It shouldn’t be done. Can you check the path by using log message. First use asset value and other whatever string you are appending to the log message.

1 Like

shouldnt be done? do you mean the orchestrator log message?

@TyraS Put Log Message activity in your process then run from orchestrator and check the logs

Hi, it actually works. I realised my mistake. Didnt know that after i publish from studio i had to go into processes to choose the latest package… Thanks @Arpit_Kesharwani @TimK :slight_smile:

2 Likes

Haha, yes whenever publish always need to select latest version in processes.

Glad you solved your issue :smile:

1 Like