Digitize Document: Invalid license for the PDF component

Hello All,

Having an issue running the Digitize Document activity. Please help to look into the issue. Following is the error:

Hi @Krishna_Murthy ,

Was a proper API Key passed for the Google Cloud Vision OCR ?

Hello @supermanPunch

Thank you for the response. I was not sure if the API key was correct.
First I used the API key retrieved from Automation Cloud > Admin > Licenses > Robots & Services and tried to run the flow.
Alternatively, I created a new project at https://console.cloud.google.com/ and got the API key, and used it to run the flow.

Both tries have the same error.


I guess it may be pdf library matter. To isolate cause, can you try to use Tesseract OCR instead of GoogleCloudVision or UiPath Document OCR? If you have same error, it’s not API key matter.


Hello @Yoichi

I used Tesseract OCR and had the same issue.


It may be caused by pdf library is not installed correctly. For now, Can you try the following step?

  1. Close UiPath Studio

  2. Temporarily remove folder c:\Users\[AccountName]\.nuget\Packges
    (To be able to recover it later, it’s good to move or rename)

  3. Re-open the project. All the packages will be re-installed.


Same error occurring. Did anyone resolve it?

Hello @ydash999!

Please share the version of IntelligentOCR package. I can check if there is a bug on our side.

Thank you!

Hi @Paul_Boca ,I started the project by creating a new workflow and it worked!Before that I had installed and uninstalled the intelligent OCR and the related packages within that project many times.I don’t know if this had created problem.

But when I create a new process ,I was able to proceed smoothly without any error.my studio version is 23.10.4 enterprise trial, and I had installed the latest intelligent OCR PKG(6.14.1)


1 Like

If you still have the old workflow, attach it here or send it to paul.boca@uipath.com and I can take a look.

Thank you!

Hi @Paul_Boca .Sorry,I had deleted that workflow.

No worries. I’m happy it works for you now.
(we had a bug with the problem you encountered and just wanted to make sure it is fixed)

Thank you!

1 Like