Digitize Document: Input document not found: {0}

I am getting this error intermittently, while using IntelligentOCR activity.
the error says ‘Digitize Document: Input document not found: {0}’. But when I check the document path the files are there.
Any idea, what could be possible reason?

1 Like

An update to the above query, I tried replacing the file in the folder by using ‘copy file’ activity.
and got the below error.
Copy File: Access to the path ‘destinationPath’. Does anyone know how to fix this access issue?

Hi Swati,

Kindly check if you have changed for each argument type as string in For each activity. And also use assign like this Documentfolder=Directory.Getfiles(“Path”).

This should work.

Hi @giri_venkat, thank you for your response. Please find below the screenshot of ‘Digitalize document’ activity.
You can see the path argument type is string and has the file name. Also the count of files in that folder is 2. I can manually copy and paste the file in the folder, it is happening. But when I try from the bot, it is giving Acess Denied.

Hi Swati,

As there are more number of files in the folder path use a for each activity before Digitize document. In For Each you can add further activities like digitize document and others.

@giri_venkat, yes you are right. That digitize document activity is indeed inside the for each loop. And it processes one document at a time.

@SWATI_KAROT Can you please share the complete screenshot of the workflow?

Hi @giri_venkat,
Please see below:

The basePath, will be the folder path which will be common for all file paths. Filename is the name of PDF document. inputPDFPath is the complete path i.e. basePath+filename+".pdf". I am assigning this to the document path in Digitize document activity.

@SWATI_KAROT Kindly try this method as shown in images
Assign -> filepath=Directory.Getfiles(“Path”) where filepath type is Array of strings and in For Each change the argument to string.

And also share your Xaml if possible. Thank you.

Hi, i understood the mistake. It was a silly one though. As I am assigning the folder path to the documentPath variable but not copying file in that folder path in any activity.
Secondly, I did try the copy option yesterday and got access denied error. I restarted my system 3 times but still no luck yesterday. But today it works after adding copy activity.
Anyways. Thanks for your help.