Dialog Box Closing Unexpectedly

studio

#1

Scenario: Click on a menu item in Oracle Cloud Services which brings up a Dialog in a new window. When a Sequence is created to just click the menu item, the dialog opens as it should. As soon as any activities are added after clicking on the menu item, the dialog immediately closes.

Steps to reproduce: Click “Export” menu, Click “Excel”

Current Behavior: Dialog Opens as expected, but when additional activities are added, the dialog closes unexpectedly

Expected Behavior: Dialog stays open and UiPath can interact with it

Studio/Robot/Orchestrator Version: Studio 2017.1.6498

Last stable behavior:
Last stable version:
OS Version: Windows 10 Prol 64-bit
Others if Relevant: (workflow, logs, .net version, service pack, etc):


#2

Still struggling with this issue, I think it may be a bug in UiPath. I can get the bot to click on the menu, select “Excel” just fine. If nothing follows those steps, the Export Options dialog opens and stays open just fine. But, as soon as I put another activity to interact with the dialog, it immediately closes. Any advice would be greatly appreciated.


#3

Hi,

Didn’t quite get it :thinking:. Are you trying to tell that export dialog closes if you try to do some other activity using UiPath ? are using recorder and when you trying to capture next steps then dialog box closes or disappear ?
If so just click F2 which allows 3 second delay in the mean time click the item manually then you can focus on the element using recorder.


#4

Thanks for the reply, what I meant was when I add activities after the click activity that opens the dialog, then when I run the program the dialog just opens and immediately closes. If the click activity that opens the dialog is the last activity in the workflow, then the dialog stays open when the program is run.


#5

ok cool.
May I know what activity your passing after click ? is it irrespective of what activity you put the dialog closes and only stays on foreground if click activity is the last activity ?
I yes then could you use delay activity after click and see dialog still disappear ?


#6

I seems to happen with any activity I add accept for write line. I have tried attach to window, click, click image, every activity seems to make the dialog close immediately at run time. I have not tried delay activity, I will give it a try. Thanks for the tip.


#7

Just tried the Delay activity, it causes the dialog box to close just like the other activities. The only one that I’ve found so far that doesn’t cause it to close is write line.


#8

@Andrei_Pop


#9

I will need to test this, do you have a link where can i find that menu ?


#10

I don’t have a link to the menu because it is on a desktop application Oracle Service Cloud (formerly known as RightNow). The instance I have on my desktop and the credentials I use belong to my client so I can’t share. Sorry.


#11

Hi,

Did you find a solution to this issue? I have a similar problem, not with excel, but with a different application.


#12

Hi Kinive, I never found a solution. The application I was building was a Proof of Concept, so I just logged it as an issue that would have to be addressed in development of the production process. Did you ever happen to find a solution?


#13

No, I did not.