Desktop Application error: "Cannot find the UI element corresponding to this selector"

Hello everyone,

I have been trying to automate a process on a desktop application. I am having difficulties even getting beyond the login page. I created the sequence below, it is supposed to run the application and type a user into the respective field, however, when I run it it successfully opens the application and starts “chewing” for a while until it returns the “Cannot find the UI element corresponding to this selector”. I tried using record, UI explorer and still haven’t been able to get the right selector. Can someone please provide any insight into what I might be doing wrong. I have already done something similar on a browser and wasn’t expecting so many difficulties on a desktop application.

I’m running Community Studio, bellow is also a list of my installed packages. In case it might be relevant I do not have administrative rights to my machine.
Packages:
UIpath.System.Activities
UIPath.UIAutomation.Activities

!

Hi @Jose_Gomes

Compare the selectors by indicating login text box multiple times and check is there any field changing each time?

Hi
welcome to uipath community
is simulate type is enabled in the property panel
if not kindly enable it and try once
Cheers @Jose_Gomes

Hello Palaniyappan!

Thank you for your quick response! I have tried enabling and ran the automation again, unfortunately the problem remains. I have also noticed that when the application starts the field that is selected by default is the password field and does not change when the Activity to type the user begins. I have also tried to change the password instead of the user but with no success.

Hello Karun!

Thank you for your help.

I have tried multiple selection options, when the application starts the field that is selected by default is the password field and does not change when any of the Activities begins, I am afraid it doesn’t select anything on the Application.

did we try with SEND HOT KEY activity with key as tab
like how we do in keyboard without using mouse click to navigate across the fields in a application
–so use n number of send hot key activity with key as tab until it reaches the field we want and once after reaching use type into activity with out any element chosen with a selector and just a input string
–and use send hot key activity with key as enter

Cheers @Jose_Gomes

Hi

As soon as the application launches send a tab hot key which will point to your login text box then use type into without any selectors use one more tab to navigate to password text box followed by enter hot key which should work.

I tried now, apparently the problem resides before the second activity. UIPath is able to open the application but then returns an error on the Selector of the Application itself before the second activity (I am sorry, I thought it was returned when begging the second activity). I don’t understand how it can open the application but still get stuck on the Selector for said Application. A print screen is bellow. Is there a way to tell the sequence to continue on error and will it be able to run Selectors on the activity even if it had return an error before?

Update: I tried using the ContinueOnError on the properties panel but without any luck.

Final Update: To anyone who might be having the same problem. I have decided to give up on having the Bot open the application, instead I manually open it for it and only then do I run the automation selecting the Elements on the already opened Application. It is not the most elegant of solutions but it quickly solves the problem, with the added advantage of being able to skip some steps that would be troublesome to reach.

did you try replacing the title=‘Autoline’/> with title=’*’/> ? Also before attempting to send log in information to an application, you can try to find the UI element with an Element Exists activity. Furthermore, play around with Ui Explorer you can often find interesting ways to target specific elements you want by name or other attributes.

Good Luck @Jose_Gomes

Hi Alex,

Thank you very much for the tips. Regarding the title, I have omitted it in the UI Selector preferences (image below). I have been "playing with the UI Explorer, tried different combinations of fields, but still with no success. I had to move forward on the automaton and therefor am using the alternative I mentioned above. However later on the road, after implementing this automation solution, I will look for improvements, if I find a way to deal with this situation directly I will let you know.

Title%20Omited

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.