Datatable Null

Hi everybody,

I have a sample process, it was working well,

today, i have a problem with this, the robot worck from start to end without problem or error,
but it create the out put file empty,
I vérified on the business app there are the data to sent to my datatable then copy that to the file ( Excel)

Thank you in advance
GetData.xaml (20.4 KB)
Main.xaml (62.7 KB)

Try adding a “Excel Application Scope” as a parent activity of your “Write Range” activity.

Thank you @Stilts
I used “Excel Application Scope” as a parent activity for “Write Range” Activity.
However, I received this error

Because I used on above “Excel Application Scope” to create my Excel file.

Make sure that the excel file you’re trying to write to is not opened by Microsoft Excel

1 Like

Your arguments are proper for the “Add Data Row” to the “Tdata” datatable and also your using the “ActiviteExceptionnelle” table variable to store the out result of the “Getdata” workflow but I couldn’t verify if all the other activities are working fine or not as i dont have the other resources required for the workflow (the excel files and its values)…and i dont see any use of incrementing of “i” in “Getdata” workflow as your while loop depends on a bool flag…Just ensure by adding a log trace inside the “Getdata” workflow if your getting the row.count for “Tdata” greater than 0 or just message the “Tdata” data using the “output Data Table” activity to just make sure that your datatable has values in it…

I solved this problem, thank you @vsibanyo

Hi @Rahul24293 Thank you for your answer,

in fact, this robot worked without any problem, and it worked very well but it did not write me on the Excel file,

looking in the files created by the robot during the tests I found that it sends datatable (my data) in the Excel file but not at the fist line A2 but at the line A199
it’s weird, why does not it start on line A2?