Customised Selector is not working in windows application

Hi, i have customised a selector and it is not working,when debugged, getting the below error message:
the ’ ’ character hexadecimal value 0x20 cannot be included in a name

My selector code is as below:
wnd app=‘winquote.exe’ ctrlname=‘DB5Form’ wnd ctrlname=‘panel20’ wnd ctrlname=‘tabControl1’ wnd ctrlname=‘tabPage1’ wnd ctrlname=‘panel27’ wndctrlname=‘tabControl2’ wnd ctrlname=‘tabFrameDeptOpt’ wnd ctrlname=‘frmoptionlist’ ctrl name=‘DataGridView’ role=‘table’ ctrl name=‘Row “+Counter4.ToString()+”’ role=‘row’ ctrl name=’# Row “+Counter4.ToString()+”’ role=‘cell’
please suggest further…

Hi @cschevuri

Pass the ctl name=’#Row+Counter4.ToString+"’ pass this only to one ctrl name

Thanks
Ashwin S

sorry i did not understand, can you please elaborate more, thank you.

you have pass the ctrl name twice pass the ctrl name only once

Thanks
Ashwin S

Hi Ashwin, removed duplicate, still not working.

Thanks @AshwinS2,
After removing one space in the selector, worked well.
"<wnd app='winquote.exe' ctrlname='DB5Form' /><wnd ctrlname='panel20' /><wnd ctrlname='tabControl1' /><wnd ctrlname='tabPage1' /><wnd ctrlname='panel27' /><wnd ctrlname='tabControl2' /><wnd ctrlname='tabIndptOpt' /><wnd ctrlname='panel17' /><wnd ctrlname='indoptionlist' /><ctrl name='DataGridView' role='table' /><ctrl name='Row "+ Counter5.ToString() +"' role='row' /><ctrl name=' # Row "+ Counter5.ToString() +"' role='cell' />"

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.