Selectors won't work when deployed to Orchestrator

Hi. I’ve got a process does some magic in Excel, and when I run it in Studio, all selectors etc. work fine. When i deploy it to Orchestrator, it fails on one of the selectors. Any input for things to look at? I’m using an asterisk in the title property (the filename is dynamic and is part of the title of the Excel sheet), but it works in Studio so should work when deployed. I’ve tried click element, click text, click ocr text etc. I’ve also tried hotkeys, same result - which leads me to think that there’s something iffy with the selectors, but I haven’t been able to figure it out so far.

This is what it looks like:

Hi @rlohne,

The selector works fine till here:
<wnd app='excel.exe' cls='XLMAIN' title='*- Excel' /> <wnd cls='NetUIHWND' idx='2' /> <ctrl name='Ribbon' role='property page' />

I guess you are using some add-on to excel. The following line is the one with the problem, the control name has an accent on it and I couldn’t get this selector since I don’t have it installed

<ctrl name ='Bandfaner' role='page ttab list' />

But you know where the problem lies.

Thanks! I’ll look into it tomorrow. It is indeed an add on to Excel.

One suggestion I have is always wildcard the application name in the title where it is redundant in the app attribute. And, also always include the filename (without extension) in the title, otherwise, it will attache to any window that is opened even if it is the wrong file.

title would be like this:
" .... title='*"+Path.GetFilenameWithoutExtension(filename)+"*' />

In order to use a variable though, you’ll need to edit the selector as an expression by clicking in the Selector property box where the selector is a string surrounded by quotations.

Using this practice has helped me a ton and never have issues anymore, because I use filename without extension and wildcard everything else for the title attribute.

Use the UiExplorer to get it validated and test it multiple times

I’ve removed this line, but the problem still persists. Works fine in Studio, fails in Orchestrator. I’ve updated the action with ClippingRegion, but still no luck. Any tips?

Yeah, sadly that’s what I’ve done and the selector is still the same.

Also, if I am logged into the machine (it’s a VM) when the robot runs, it works. If I’m not logged in, it doesn’t work. Resolution issue? When logged in i’m at 1440p, and I’ve set the same resolution in Orchestrator settings (32bit resolution depth).

And by logged in I mean I’m watching in a remote desktop. If the remote desktop isn’t connected, it saves the excel file from an e-mail and opens it, but fails to click the addon ribbon.

Yeah please check the resolution, if it is image dependent. Make sure they are the same resolution, if not modify the robot config in the Orchestrator.

An alternative would be to use Keyboard shortcuts to reach to the ribbon, since I don’t have that add-on I couldn’t give you the direct keys combo, it’s worth a try:

Good luck!

I get the same problem; i.e. it times out. It seems like it’s less selector based problem, and more that the robot cannot find any UI Elements. I’ve tried multiple workflows with many different applications and nothing works. I’ve read that logging in as console can create this problem, but that option is disabled in the robot settings page. I’ve contacted UiPath Support because I’m at a loss.

Hey @rlohne

did you find a solution to your problem? I’m facing the same issue, would love some help!


Hi. I did indeed solve the issue. I had to reinstall the UiPath platform and make sure that the robot was actually running. The robot wasn’t properly installed, just Studio. Reinstalled and it worked fine.

Hey @rlohne,

thanks for your reply! For me it is just one application that does not run, but i hope your solution will also solve my issue. Ill try it, thanks!