Custom Activity not being downloaded by bots

orchestrator
custom_activities

#1

I have created a custom activity, and I deployed to my orchestrator activity feed
I manage to develop the script just fine with the custom activity, however, when I want to execute the script in another machine, I get an error:

Execution error : System.Xaml.XamlObjectWriterException: Cannot create unknown type '{clr-namespace:My.Custom.Assembly;assembly=Custom.Assembly}MyAssembly'.
at System.Xaml.XamlObjectWriter.WriteStartObject(XamlType xamlType)
at System.Xaml.XamlWriter.WriteNode(XamlReader reader) 
at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter) 

I can solve this error by manually installing the activity, but this seems counter-productive since we have lots of machines in need of that activity.
According to this link, https://orchestrator.uipath.com/docs/about-the-activities-feed everything should work, and the scripts are supposed to download the custom activity, but this is not happening.


#2

Hi @bruno_cw

From my understanding, and this goes for all activity packages, you must install them on every machine for every user id being used by Robots.

Hopefully, package deployment gets improved in the future though, cause I agree that is counter-productive and everytime something gets reset with Studio someone needs to go do all that. It would be better if the packages would install per machine rather than user.

Regards.


#3

Hi @bruno_cw, @ClaytonM ,

I’m facing the same issue and the same error (System.Xaml.XamlObjectWriterException: Cannot create unknown type '{clr-namespace:…) is logged. As per what @badita mentioned here : How to deploy custom activities package, It should work as described in the resource articles. Any luck resolving it?