Could not start executor. The wait operation timed out. (Exception from HRESULT: 0x80070102) RemoteException wrapping System.Exception: Could not start executor. The wait operation timed out. (Exception from HRESULT: 0x80070102)

Hello,
I am getting the following error frequently in one of the VM.

Could not start executor. The wait operation timed out. (Exception from HRESULT: 0x80070102)

RemoteException wrapping System.Exception: Could not start executor. The wait operation timed out. (Exception from HRESULT: 0x80070102)

Any idea how to fix this

image

Good day

I am getting the same error periodically.

Anybody know why?

Thanks

I am facing the same issue. Restarting the Robot machine resolve the issue temporarily but it occurs again within a week time. Seems to be a serious issue. Did anyone found the reason or solution for this ?

Has anyone had any luck resolving this in the past year?

I am also getting the same error when using Elastic Robot Pool. It looks like the VM takes very long time to provision and get into a ready state. And the job time out. Does anyone have a solution?

Hey ,

Did you find any solution ? I am facing same issue in machine.

Thanks

Someone who has an solution for this issue? Have to deal with the same issue. Strange thing at it is that just one specific process gives this error.

This issue may happen when MFA (multi-factor authentication) is turned ON for the robot machine. Having MFA enabled on the machine doesn’t let the robot login into the machine and run workflows in Unattended mode.

To resolve the issue you may try these:

  1. Remove the group policy that enforces MFA on the machine.

  2. Check internally with your Network team to see why is taking so much time to connect your Robot to the Orchestrator server.

  3. Increase the UIPATH_SESSION_TIMEOUT system variable to 300 and restart the machine. This will allow more time for the second session to be established. If you don’t have that variable created, create it.

  4. Make sure that the robot is not disconnected from Orchestrator.

  5. In Orchestrator, edit your robot settings and enable the LoginToConsole to active and set its value to No, and make sure that the Robot machine is signed out (in a cmd.exe type logoff) before running the job from the Orchestrator.

  6. Check if you installed the Robot in Service-Mode. For that in services.msc you should see UiPath Robot service running under a Local System account.

  1. Check this documentation as well Frequently Encountered Robot Errors