Could not start executor. A specified logon session does not exist. It may already have been terminated

Hi everyone. Has anyone faced this issue starting a job for unattended robot from Orchestrator: "Could not start executor. A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520)

RemoteException wrapping System.Exception: Could not start executor. A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520)"?

Regarding robot settings I enabled “Login to console” setting it to “No” and I have set the resolution parameters. Everything was working correctly until a few days ago: the issue arose already a few days ago, but it resolved automatically within a few hours. This time, however, the problem has persisted for two days. I guess it isn’t Orchestrator related since the robot settings for unattended are correct and the robot is correctly licensed and connected. Thank you so much for any help.
Job details_Could not start executor

1 Like

Was the robot installed in the machine in service mode?
I’d try reinstalling UiPath in the robot machine using the .msi installer and make sure you check service mode in the installer, otherwise this kind of issue might arise.

Hi Lucas, yes, the robot is installed in service mode. Thank you for any extra help

Ok, let’s see, I have faced issues when I logged into the VM and just disconnected or closed the remote desktop app, without properly logging out.
Perhaps trying logging into the VM with the robot user and than finding the proper Log Out option to close it might help.

Other than that, I’m out of ideas.

1 Like
  • Does this occur for EVERY job you attempt to initiate for this particular Robot/Credential and Machine? Or occasionally?
  • Verify the credentials you are providing to the Unattended Robot including the format of the username <domain>\<username> As you didn’t specify if you were using a Domain Join Machine or Domain Credential vs Local
  • Are there any warnings when you RDP into the host manually with the same credentials such as an authorized user warning, etc.

An older KB, but covers some common scenarios I would go into depending on the above and symptoms you have and steps to reproduce.

Dear Vincenza,

I have been encountering this error since a month…It occurs sometimes and not always.
Could you please share the fix for this which you tried to resolve the error.

I am having an unattended multibot process whic runs daily in HD VM set up to run by triggers.
Not all the jobs fail,One or two robot (multibot) user fails.

Thanks

Using the msi installer 20.4.5 to install the Assistant, but I don’t see a Service mode option.

Assistant on VM:
image

HI Ferdinand,

I am also facing the same issue but not all the time only some times my job is getting faulted due to same error. Did you got the solution ?

Hi Vince,

Did you got any solution for this error. Even im facing this same issue…

Thanks,
Robert.

Hi Everyone, I have been encountering this error too. I figured this is because the orchestrator could not login to the robot as it was already occupied with someone else logged in with a different username. In my case the robot is a 2019 data center server and it can take up to two users at the same time. Whenever I get this error, it is because two other human users were logged in to the server at the time that this bot was scheduled. Once one of them logged off, the bot was able to run successfully.

Check if this is helpful and mark it as the solution if it does.

Hi
I am also facing this error any resolution for that and why it’s happen please help me.