Could not load type ‘UiPath.SmartData.Utils.ApplyOcrOnPdf’ from assembly ‘UiPath.SmartData.Utils, Version=, Culture=neutral, PublicKeyToken=null’

Hi everyone!

I’m getting this error when I try to digitize a PDF file. Here are the steps I took:

  1. Create a new bot from scratch in my machine, and have the following dependencies updated:

  1. Run the Digitize activity with the UiPath Document OCR engine; the ApiKey; and on the a PDF document in a shared folder. The bot worked normally.

  2. Transfer the folder of the bot to a remote shared directory, so it can be accessible in other machines (it’s a necessary procedure).

  3. When I run the bot again, I get this error:

Could not load type ‘UiPath.SmartData.Utils.ApplyOcrOnPdf’ from assembly ‘UiPath.SmartData.Utils, Version=, Culture=neutral, PublicKeyToken=null’.

Is there something I can do to resolve this issue?

Hello @Slgus Can you try the below steps and see how it goes

  • Remove Unnecessary dependencies
  • Update Intelligent OCR Activities
1 Like

After several hours, we manage to fix this issue by changing the versions of some dependencies and getting rid of some other ones. Just update them to the last version wasn’t working. Also, the Studio version I’m using is 2020.10.2, so some activities wouldn’t work with the last version of each dependency.

To sum up, this are the versions we used to make the Digitization work:


Thanks @ushu for the response.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.