Could not load file or assembly


#1

Scenario:

Current Behavior: Unable to use activities

Expected Behavior: Be able to use them

Studio/Robot/Orchestrator Version: Studio 2018.1.0

Last stable behavior:
Last stable version:
OS Version: Windows 10 Pro, 64 bit
Others if Relevant: (workflow, logs, .net version, service pack, etc): .NET 4.0.30319.42000

Hello guys, at the moment I am trying to use extension package, I was able to install this package, but I am facing a problem with kind of “dependencies” - so I am not able to use activities from this package. Error message:

erropr

I am not sure how to work with this NuGet dependencies but I used same steps just like with package. Is there anybody who does know, how it works and what should I change?

Thank you in advance.

Jakub


#2

Hello,

Are we talking about Microsoft Activities Extensions package?
When do you see that error?


#3

Hi @Gabriel_Tatu,

no, it is something that is not part of Microsoft Activities packages or any similar. That is why I am aiming to find someone who works with NuGet files and maybe can give me an advice how to install “dependent files” correctly

Thank you!


#4

Hi @jakubvanhara

Will you try to download this nuget package and install it then try to load and update what you are getting after that

Regards…!!
AKsh


#5

Hello @aksh1yadav!
I do have all packages installed but the thing is if in the right way:

br


#6

No you have manually placed it there right? because Nuget package does not follow uipath namespace to show nuget package that is why dependency issue is generating but if you just want to use the .dll methods you can place that dll there and use those methods :slight_smile: or let me see it as well

The error was of namespace collision i guess.

Regards…!!
Aksh


#7

Try this package ? NitoAsyncExActivities.4.0.1.nupkg (158.2 KB)

your package is for android, xamerian and alot :o:

Regards…!!
Aksh


#8

Ah thanks. But the only way I know (how to “install”) is to extract this .nupkg file (using 7ZIP or something), so I will get “lib” file. And as you said - only manually placing it. So what is the right way?


#9

Now it is working for you?

Adding Your Own Packages

  1. In the Manage Packages window, in the left panel, right-click any category.

  1. Select the Configure Sources from the context menu. The Package Source Settings window is displayed.

  2. Click the Add image. A new blank package is added and an error message is displayed because the Name and Source fields are not filled in correctly.

  3. In the Name field, type the name of the package.

  4. In the Source field, type the local drive folder pathway, the shared network folder pathway or the NuGet feed URL of the package.

  1. Click Apply. Your configuration is saved.
  2. Click OK. The Package Source Settings window closes. Note that the Name is displayed in the Manage Packages window, as a new category.

REgards…!!
Aksh


#10

Awesome!! That explains a lot. I had really no idea how to work with these packages. Thank you very much @aksh1yadav !!

I really appreciate your approach.

Regards Jakub