Could not load file or assembly ClosedXML


Hello, I am currently on test phase on a robot and encountering this issues:

1. Robot stopped due to the below error. Try Catch is wrapped around the process error found, but seems like the error was more fundamental, it stopped the robot. Log said:

Error {“message”:“Could not load file or assembly ‘ClosedXML, Version=, Culture=neutral, PublicKeyToken=XXX’ or one of its dependencies. 指定されたファイルが見つかりません。”,“level”:“Error”,“logType”:“User”,“timeStamp”:“2018-06-30T08:35:04.9021654+09:00”,“fingerprint”:“XXX”,“windowsIdentity”:“XXX”,“machineName”:“XXX”,“processName”:“XXX”,“processVersion”:“XXX”,“fileName”:“XXX”,“jobId”:“XXX”,“robotName”:“XXX”}

2. Went googling about ClosedXAML, and found some articles to install manually the ClosedXML.dll, but I am not sure since we’re using the client’s environment and we need pretty lengthy procedures to have permit to install anything, and it was not even in UiPath forum.

3. What made me even not sure was that the robot works daily, and it has been about 10 days, and only 2 days they fail with the same error above. So there are days when it works fine. If a dll file is missing, I think it shouldn’t work at all.

4. Additional info:
UiPath Version: 2018.1.4
UiPath.Excel.Activities Package Version: 2.3.6660.23035

So far the error appeared twice on different machine, and reinstalling robot was done, but the error still occured then.

Notice: could not easily upgrade any version of this since there are some previous robots working, we need to test it for sometime before applying to upgrade any version.

Any help would be appreciated.

EDIT: (added information)

Looked for my Studio and found the ClosedXML is installed in version (and the log said error was dould not load (version below). Thought this could be the problem, but cannot find where the ClosedXML setting is, and still wonder why they work sometimes too.


Again sorry for direct pointing, but could you kindly help on this, @ovi?


Let me understand:
-when did this error appear?
-those workflows worked? If so, with what version of excel and robot?
-is the closed xml package v0.87 downloded on the robot machine?


Hello @Gabriel_Tatu, thank you for your response.

-when did this error appear?

When reading an Excel file using Read Range on Excel Application Scope.


-those workflows worked? If so, with what version of excel and robot?

It worked mostly. But, there are days when they failed (not always failing).
UiRobot version, Excel 14.0.7145.5000 (32bit), Microsoft Office Proffesional Plus 2010.
UiPath.Excel.Activities Package Version: 2.3.6660.23035.
When failing also using the same machine, the same robot and the same Excel version.


-is the closed xml package v0.87 downloded on the robot machine?

Never directly installed it, but when checked from Studio, ClosedXML version is installed. But when error happened, the log said the ClosedXML version could not be loaded (the version is difference).



Now I am facing same problem. yesterday It’s working fine.

System error at initialization: Could not load file or assembly ‘ClosedXML, Version=, Culture=neutral, PublicKeyToken=fd1eb21b62ae805b’ or one of its dependencies. The system cannot find the file specified. at Source: Read range settings

Studio I am using is 2018.2

please help


Hi @irahmat, have you tried to uninstall and reinstall the Excel activities?

Getting "Could not load file or assembly 'UiPath.Interop, Version=9.0.6844.26814' error

I followed this solution

and it’s works.

1 Like

Nice to hear it worked for you.

1 Like

Lots of bugs are comming in UIPATH since last 2 days. I am not able to publish my projects .God know why these issues.


I have the same problem as described here. If I look in my Package Manager I have version 0.94 of the closedXML, but my error messaeg is also relating to the v0.87…

As was suggested above I tried to go to C:\Program Files (x86)\UiPath\Studio\Packages and delete the ClosedXML and ExcelActivities packages before installing again from studio package manager, but the same error occurs. Also, after reinstalling from studio, the nupkg files are still not reappearing in the folder from where I deleted them, not sure if that is an issue?

I tried moving the files back into the Packages folder again too, and deleting again, and restarted my computer…

Does anyone from UiPath have a solution to this?


Hi @tea

How about clearing the folder:

Does it help?


I got it to work after reverting back to old versions of the openXML and closedXML packages, still a little confused as to why, but at least it is working now. :slight_smile:


Could you please detail how to revert to old versions of the open XML?


Hi, I think I saw in the exception message which version I needed, and then I went to package manager, looked up the package and chose that version instead of the latest one.


Hi I try to roll back my closedXML, funny thing is, I cannot find ClosedXML in activity manager, but the new version do exist in my activities folder, any idea?

My Closedxml version is 0.94
My error message said this:


Hi all

I solved it!

Just uninstall my uipath, reinstall my uipath, the error gone.


Open Browser: Could not load file or assembly ‘UiPath.Interop, Version=, Culture=neutral, PublicKeyToken=461894da7f0ba157’ or one of its dependencies. The system cannot find the file specified.

I am facing this error while after reading csv file when i am trying to Open Browser