Could not load file or assembly 'ClosedXML, Version=0.87.0.0

HI to all,

I have read the other topics related to this subject and I have not managed to find a solution.
I am having this issue upon running a process in a fresh new environment.
The process uses REF and the error occurs in the INIT state, in Init Settings. when trying to reach the Config file.

I uninstalled all the packages and reinstalled them but it does not seem to work.
I also tried adding manually in imports ClosedXML and DocumentFormat.OpenXML - not working.

If I create a fresh new project on the VM it reaches and runs this flow.

What else should I try in order to make the process run in the Environment?

Thanks in advance,

“Read range (Settings and Constants sheets): Could not load file or assembly ‘ClosedXML, Version=0.87.0.0, Culture=neutral, PublicKeyToken=fd1eb21b62ae805b’ or one of its dependencies. A strongly-named assembly is required. (Exception from HRESULT: 0x80131044)”

Hi @rspantu

Please have a look at the below thread.

Hope this will help you. Thank you.

Thanks @Jobin_Joy for taking the time to reply to my thread.

These solves were already tested before issuing the thread.
Moreover, my process relates to an excel of 24kb, with 2-3 sheets and maximum 10 rows.
This is located in the project folder as a Config file. The process does not have Excel activities package installed as this is not required.

The issue still persists.

Warm regards,
Radu

Kindly ensure you installed the below package into your project.

Read Range activity will be utilizing the above package to perform the respective actions internally.

Thank you.

Hi @Jobin_Joy ,

Thanks again for taking the time to reply to my thread.
I am not reading the file using the Excel Activity scope, as MS Excel is not and will not be installed on the VM.
The file is brought to the project folder and read with the Read Range activity within the System scope.
This activity Read Range does not require UiPath.Excel.Activities package to be installed.

The only fix I can think of is to create a fresh new Framework in the environment and copy the developed workflows to replicate the process architecture.

Regards,
Radu

Can you please share the code base here as a zip file after removing sensitive data if anything?

So that I can look into the code and fix it.

Thank you.

Hi @Jobin_Joy ,

I can honestly say that the code is not the issue.
The same workflow (not even a log message or a comma are different) works smoothly in another project within the same environment.

The code is the standard one generated by the REFramework.

Thanks,
Radu

How about reinstalling UiPath Studio and trying the same?

This is about the ClosedXML package part of the Excel Activities that’s not working.
I tried uninstalling, even deleting the folder from the .nuget/packages, and then reinstalling. Nothing works.
The only workaround I was able to find - up until this point - was to create another project and copy the existing workflows to rebuild the process architecture.

Any other ideas are welcome.
If I find the actual solution to this, I will, for sure let you know.