Could not add Robot manually

Hi everyone,

I could not add robot manually. I have created standard machine and connected uipath robot app. Can someone help me where i went wrong?

Refer this

I am still not able to add robot. I did managed to add users and they are reflecting under robots page but still not able to add robot manually. Also the machine i have created is not showing any robot.


You are trying to add a robot in the tenant option.

Go to Default or My workspace folder and add there…

Those robot will automatically be reflected in the tenant

Yes as @Pravin_Patil1 said, You need to add Robot from Default → Robots → + (Add) → Standard Robot

The same was mentioned in the screeshots of the post.

I am not getting default option in orchestrator. See the attached Screenshot:

I am not getting add robot option in My Workspace too.


that is because you have limited access to your id…
Get full access using assign role

Under tenant? Could you elaborate more on this?

Refer below

@ pravin_patil1 I am not even getting default folder.
FYI : I have community version installed.

@Sakshi_Gupta You can do the same in Shared Folder… Or else go to the tenant option and add a classic folder…

I did the same but still not getting option to add robot

Hi @Sakshi_Gupta

Click on Tenant

click on Settings

in General Tab

Check if

Modern Folders

Enable user-machine mappings is checked, if not enabled, enable it and save.


in UiPath assistant Sign in with your Orchestrator log in credentials … this will add Robot

1 Like

@AdityaVN My robot is connected to UIPath assistant but i could not add robot “not getting + icon”.

@Sakshi_Gupta when you say + icon do mean the sign I highlighted in the screenshot?

this would appear only in Classic folders, with respect to Modern folder, Robots run in the context of a user identity. This mean based on the user role robots gets assigned
You can have more details from this link :point_right: Robots

My understanding is you are working in Modern Folder and you might have a something as below screenshot

Furthermore if you click on Users(below screenshot) you will be able see assigned Robot to a User

Hope this was helpful

Yes exactly the highlighted sign. Since i am unable to see default folder I created one classic folder but under that too it’s not coming.

Secondly, in modern robots robots assigned automatically based on users? Is that what you are saying? If it is true then it’s okay my robot is connecting to orchestrator.
But still in classic folder I should be able to add one.

Are you able to resolve the issue Sakshi? Because i am also facing the same issue

No @ Jyoti Bora I am still not able to add the robot.
However modern robots are working fine but can add or modify robot.

Hi Sakshi,
Could you please clarify what do you mean by saying that modern robots are working fine? I have the same issue - not possible to add robots using Modern Folders. In settings it says "Classic folders cannot be activated for the Community plan. "…