Copy Select Text: Message one or more errors occurred

Hi team,

I’ve created a flowchart, basically, I get information from excel using
Select Range → Copy Select Text → Set to Clipboard → Basic (in this activity I open SAP transaction and paste the result from clipboard).
So, the whole process works very well but when it arrives at the end show the error message:

Do you know what I need to do here?

Hi @eduardo.marchesin
Welcome to UiPath forum !
Would you mind sending a copy of the whole error ?
(From RemoteException to the end)

Hi Hiba,

This is the error message that show me after the whole process.

Thank you @eduardo.marchesin !
But in order to understand more the error, I need you to copy/paste what is inside the error box starting from RemoteException :grin:

HI Hiba

Insidde the error box has:

RemoteException wrapping System.AggregateException: One or more errors occurred. —> RemoteException wrapping System.Exception: Empty clipboard

at UiPath.Core.Setup.GetClipboardText()

at UiPath.Core.Activities.ClipboardWrapper.<>c.b__4_0()

at UiPath.Core.Retry.Do[ResultType](Func`1 action, Int32 timeoutMS, Int32 retryCount)

— End of inner exception stack trace —

at UiPath.Core.Activities.ObsoleteTaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)

at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)

at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)



Hi @eduardo.marchesin, after selecting the range in excel, you can pass a send hot key and copy that selected text. I hope it will work.

Definitely, the error that the robot says is that it can’t copy when there is nothing to copy.
In your workflow, does a case happen when you select range of nothing? Or did you check that the robot selects properly ?

Anyway, several people had the same issue as yours and ended up droping copy selected text to the option that points @Shivaraju
See here the details of the option

Maybe try to replace that 2 activities (copy text and set to clipboard) with “send hotkey” ctrl+c. It will act like user and should copy that datatable :wink: My guess is that copy selected text not works with datatable from excel (but I never tried to use that way)

The whole process works very well until at the end, the process includes copy a range in excel, open an SAP transaction paste the values on this option, and put to execute in background. It is working very well, only when the process arrives at the end show me the error message. I’ve tested and after finish the process I’ve opened the notepad and with Ctrl+V paste the clipboard, the information was there. The number of items was the same among excel and clipboard.

Have you tried to copy that result manually and paste it to SAP? Maybe there is problem with selector?

What kind of error do you get?

The error is mentioned above, it is related to Source: Copy Select Text, and it happens only at the end of the process, the workflow runs perfectly…

I can not use the manual paste, because in SAP if you use CTRL+V it pastes only 8 first registers and my list has more than 2000 registers.