Copy Select Text Error


Source: Copy Selected Text

Message: One or more errors occurred.

Exception Type: System.AggregateException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.AggregateException: One or more errors occurred. ----> System.Exception: Empty clipboard
at UiPath.Core.Setup.GetClipboardText()
at UiPath.Core.Activities.ClipboardWrapper.<>c.b__4_0()
at UiPath.Core.Retry.Do[ResultType](Func`1 action, Int32 timeoutMS, Int32 retryCount)
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I am getting this error while i am trying to copy text from Remote Desktop using Select and Copy option.

Please help me to solve this issue
Thanks in advance


Welcome to the UIpath Community.

As you said, you are trying to copy the text from remote System. So, use screen scraping method with OCR engines. It will give accurate results.


There are two ways to achieve this:
-Use Image Automation
-Use Citrix automation(For this UIPAthRemoteRuntime must be installed on the target remote machine)
The purpose this remote runtime is to convert the remote environment to your native environment and thereafter you can use the get text activity and it will allow you to capture the respective elements with the appropriate selectors.

Hi @Abhilash_Bhima

Welcome to UiPath community buddy
Fine the error is actually because of this, it didnt get copied to the clipboard and it throws error when we try to get the value from clipboard being without any value…

For this kindly enable the property Sendwindowmessage in copy selected text Activity and kindly try with IE instead of chrome if this is performed in a web browser

Hope this would help you
Kindly try and let know for any queries or clarification
Cheers @Abhilash_Bhima

Thanks for the reply. but we are getting entire text from the remote desktop by using OCR engines but i want selected data. I want to know why this error occurred. i want to work with Copy Selected Text option.

1 Like

Thanks for the response. I want to copy data from the UIDemo application in remote desktop. i had tried by enabling the Sendwindowmessage i am not getting any error but i am not getting any text into that variable which i am trying to display using message box. Even i had tried in IE i am getting empty message box opening. is there any possible solution to get the text kindly help me.