Command Timeout in Execute Query/Non Query activity

i_completed
database
activities
r_18_1

#1

I have seen multiple tickets and issues regarding the insufficient (in some cases) default timeout of 30 seconds used in Execute Query and Execute Non Query activities. I know this is the default for SqlCommands, but I’m thinking we should be able to expose the CommandTimeout property from the SqlCommand, as a property of the actual UiPath activities.


#2

This is greatly needed. We are experiencing issues with queries that run over 30 seconds but a few seconds and they fail.


#3

I agree, this it very important feature that is required !!!


#4

+1 :slight_smile:


#5

will do.
till then there’s a workaround: Change Database Query Timeout


#6

Thanks
Do you know when it will be available ?
The workaround is not clear… how to get a correct datatable using this increase of timeout ?


#8

Hey badita,

It’s been almost 8 months, you replied still you people not found the solution to expose timeout input argument?
This property is pretty handy while executing long duration queries. Please release the updated activity along with the Timeout Property.


#9

Hey mihai.pricochi,

You have getting multiple tickets means, you should provide that option as per as early. We are facing problem while executing long duration queries.


#10

There are many ideas and multiple priorities.

As of now there is an workaround for this and it has no votes :slight_smile:


#11

But this will for connection timeout. How to give command timeout?


#12

Well… actually have been implemented and is there … :slight_smile: The naming is a bit confusing so we will make it SQLCommandTimeout in the future.


#13

Yeah… Thanks :slight_smile: