Click Activity with Simulate Click


Click activities with ‘Simulate Click’ selected no longer work with our web-based business system. The click activity thinks it has worked and the workflow moves on to the next activity, but the click has not actually been performed.

Sample HTML elements (as they appear in the HTML):

One element is a javascript link
<A href="javascript:SetView('../pa/EmplProfile');" TEXT_CAPTURE_X_CUSTOM_ID="275656259328113|A">Profiel</A>

The other is a button
<INPUT id=cmdCustHist type=submit value=Tewerkstelling name=cmdCustHist>

All activities work with UiPath.UIAutomation.Activities version 19.2.0 and earlier but do not work with 19.3.0.

Steps to reproduce:

  • open / attach to an internet explorer window with the business system open
  • click a link element

Current Behavior:

No click occurs, workflow continues on to next activity.

Expected Behavior:

Click should occur.

Studio/Robot/Orchestrator Version:

Last stable behavior: 19.2.0
Last stable version: 19.2.0
OS Version: Windows 10
Others if Relevant: Internet Explorer 11.379.17763.0

Hi @Foehl

Could you check with the beta activity pack and see?

Hey Maciej, I set studio to Beta and updated both packages (UiPath.UIAutomation.Activities & UiPath.System.Activities) to version 19.4.0 but the simulate click activities still do not work. Rolling the activity packages back to 19.2.0 gets them working again.

Would you be able to provide a sample xaml file? It would be easier for our team to look into specifics of the selector and to be able to track down the issue.

1 Like

Sure, I’ll pull out a representative workflow section and post it shortly


Thank you. Our team is having trouble reproducing it, so it would be helpful :slight_smile:

Hi Maciej, here’s a sample workflow that demonstrates the issue we have. It’s obviously of limited use as you don’t have access to our business system, but hopefully it will help.

AC_004_Evobizz_Navigate_Consultant_Tewerkstelling.xaml (8.1 KB)

If it doesn’t help you to re-create the issue, let me know and we’ll look at making an example workflow using a public site.

Hi @Foehl

Thank you so much for this sample. Our team looked into it, but didn’t manage to reproduce :frowning: Could you maybe recreate it using a public site?

Some screenshots of how the elements look like might also be helpful.

Hi Maciej,

We haven’t been able to recreate the issue with public sites. I’ll message yyou some screenshots that will hopefully help to pinpoint the issue.

1 Like

Thanks, we will investigate further. In the meantime, feel free to check if the latest 2019.5 version of the UiAutomation, just to be sure we’re not diving into something that was already fixed :slight_smile:


If you have tried with no results (and you are on the Enterprise edition), then please create a ticket with our technical support. It would help to have all the logs (including low level ones).
It seems that it is an issue with a specific app and is otherwise hard to debug.