Chrome extension malfunction after auto-update to 22.4

I do have similar issue together with some others!!

after update to 22.4
my dear @loginerror can you ask you colleagues ? :slight_smile:

1 Like

Hi @Mike_Campbell and @Roman_hruska ,

I can confirm that this has happened to me just yesterday. A short video of it can be found at the end of this tutorial. The popup does not stop the automation, but the chrome extension and the PC needed to be restarted.

@ 29 seconds

Thank you for the reply. The video does show the same debug message I receive, so I was hopeful rebooting would do the trick, I have done so and it still has the debug message.
While it does TYPE on the webpage, it does not click, so it is certainly impaired and not just cosmetic.

My bad. I did not menn the issue was fixed after a reboot. The extension did not come back up after the auto update so I choose to restart the machine.

The click on that hyperlink in the video worked on my end but I have not tried actively left clicking on an element. I used the modern experience (Openapplication/browser activity)

This issue still persists in the community version of UiRobot/Studio

This issue still persists in the community version of UiRobot/Studio

Yikes. Seems pretty severe to not be getting more notice/comments/engagement.

So I feel both not alone as others report same … and yet… alone. :frowning:

Having uninstalled and reinstalled (current) a couple of times with reboots between, I decided to try installing an old version again briefly - (I had 21.10.5 installer) Even knowing it will require update nearly immediately.

Installing 21.10.5 and it’s matched plug-in did restore all Chrome web functionality, so I can confirm the issue is specific to the 22.4.0 update. :frowning:


Hello @Mike_Campbell !

Can you please share a workflow that reproduces this issue?
If not, then let’s please connect via Zoom to debug this.

Hi @Marius_Stan,

You can use the workflow I uploaded here.

Users modern experience and I have checked it behaves as @Mike_Campbell posted above on the newest 2022.04 auto update.

Hello @jeevith !

I’ve tried now the BrowserTabManpulation.xaml that you suggested.
But this works fine on my end with UiAutomation 22.4

Can you please describe what problem you are seeing when running this workflow?

PM’d to set up zoom/teams which might be beneficial (I can’t directly share the code)
I suppose it is possible the new plug-in only has issue with specific selector methods or calls…

I also had the same problem with this update and since that pop up would disappear and reappear shortly after changing each web page it also caused problems with selectors with references (anchors).
I solved it by reinstalling the extension as suggested here Edge Browser Popup With "Uipath Started Debugging This Browser" | How To Turn Off - #14 by gheorghestan

The popup is not shown if the extension is installed via group policy. Here are specific instructions on how you can achieve this. Keep in mind, you need admin privileges to be able to install it this way.

In my case the installation path is not as described in the programs folder but in Appdata (per user) and maybe that’s the cause that created the problem, but I simply clicked update when prompted by Uipath (it didn’t ask if per user or as administrator).

1 Like

I have the same error after updating to 22.4 community stable release and all my bots have stopped working but I do not understand how to install using group policies as suggested in the link. Can somebody make a detailed description how to solve this problem?

I installed it in this way:

Open a console (cmd.exe) as admin

Write this replacing < installation path > with its own path where uipath is installed (and if there are spaces in that put " before and after the whole path). You can find it by doing open file path on the uipath shortcut and repeating this until you find the. exe:

cd < installation path >
cd UiPath
SetupExtensions.exe /chromepolicyglobal

Done. No needed the others commands written in the link.

1 Like

Thank you very much for the explanation:-) In my case the filepath was:

So to others facing the same problem write cd filepath and then:
SetupExtensions.exe /chromepolicyglobal

1 Like

@Werve - This 98% resolved my issue!
I’m going to be a bit more explicit in steps for those trying to follow:

From the workstation I followed these steps:

  1. Opened Chrome and REMOVED/Uninstalled the broken Chrome Extension.
  2. Close Chrome
  3. In Start menu, I right-clicked Studio shortcut, clicked More>Open File Location
  4. One layer deeper, I right-clicked the Studio shortcut again, selected >Open File Location
    That opened an explorer window in my case to…
    C:\Users[my name]\AppData\Local\Programs\UiPath\Studio
  5. Per Werve’s note, I went one layer deeper to
    C:\Users[my name]\AppData\Local\Programs\UiPath\Studio\UiPath
  6. I copied that path to clipboard.
  7. Opened an Administrator command prompt.
    (in Search box type Command, then right-click and choose “Run as Administrator”)
  8. type CD [space] and paste in path from #5 above and press ENTER.
  9. type SetupExtensions.exe /chromepolicyglobal

A dialog box comes up stating “The UIPath extension for Chrome was installed via policy per system.

I opened Chrome and confirmed the plugin was reinstalled AND ENABLED. there was no need to enable it separately.

At this point, I decided to test my project again,

I did still have ONE remaining glitch:
- the project was still hanging up at a specific Click (to search in the webpage) It was using a >click< action with “simulate click” option enabled, this option was previously working most reliably of options. I changed the option for this action from Simulate Click to >> Send Window Messages.
This resolved the remaining hang-up and the rest of my project ran as it did prior to the update.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Hi @Mike_Campbell

I chatted with @gheorghestan and this is a topic that should provide more context:

The core of this issue comes from the fact that the Google’s new MV3 extension standard is not that great and offers less support than the old MV2. This combined with the fact that starting with 1/1/23 Chrome will not load MV2 extensions anymore makes this a tricky situation.

We are continuously looking out for new solutions in this area, but in the meantime you might indeed have to switch to Send Window Messages as a workaround.

And just to make it clear - the debug pop-up in Chrome is absolutely normal and has no real implication on the functionality of the UIAutomation.

1 Like

This turned out to be a confusing coincidence where the plug-in debug warning began appearing at the same time the next step in my automation failed due to the update. So while I was trying to solve the popup (thinking everything was broken) it was a co-symptom of the Chrome MV3 “upgrade” which made my simulated click no longer work…

Glad to be back in business, and I do hope something can be done to smooth the install routine for the plug-in upon upgrade… THANKS AGAIN to all in this thread.

Just to add to what my colleague Maciej @loginerror posted above.

22.4 Simulate Click not functioning in some scenarios . This happens when certain webpage buttons have handlers in “javascript: ” format .

Example of a button with a “javascript:” handler

<form action="javascript: window.location.href='FormHandler.html';" method="get"

Root cause

This is a technical limitation introduced by Google’s rollout of the Manifest V3 update to their Chrome extension platform.

Proposed workarounds

Please try and use as input methods, the following :

  • 1) ChromiumApi
  • 2) Send Window Messages
  • 3) Hardware Events