Can't upload files using SFTP connection

Hi Everyone

So i have an automation that needs to upload some files from a folder into an FTP site.
Up until recently we used a normal FTP connection but for business reasons we need to switch to the SFTP protocol, while FTP worked fine, after checking the SFTP box on the “With FTP session” configuration box I get this error.

I have tried using FileZilla to make sure the username and password works and I have no issues with it, however when doing this through UiPath i get the follwing error.

Main has thrown an exception

Source: With ftp session

Message: No suitable authentication method found to complete authentication (publickey,keyboard-interactive).

Exception Type: SshAuthenticationException

Renci.SshNet.Common.SshAuthenticationException: No suitable authentication method found to complete authentication (publickey,keyboard-interactive).
at UiPath.Shared.Activities.AsyncTaskNativeImplementation.BookmarkResumptionCallback(NativeActivityContext context, Object value)
at UiPath.Shared.Activities.ContinuableAsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Am I missing something here ?

You using FTPS or SFTP?
FTPS: ftp protocol using SSL, UIPath: choose FTPS mode
SFTP: ssh tranfer file, UIPath: Check Use SFTP

SFTP, yes I did check the use sftp box but there is an authentication error, the screenshot is from the “with FPT”

FTPS is not enabled on our system as far as i know