Can't select an UI element

I’m working on my first UiPath trial but got stuck on an UI selection issue.

Basically, I’m trying to click a text box and key in a date but UiPath keeps prompt me that “The UiElement is no longer valid”.

Here are what I’ve tried but didn’t work

  1. Adding delay before the click activity
  2. Using Anchor Base
  3. Select an item on the screen which can be recognized by UiPath and send multiple “Tab” keys

Can you share screenshots of your selector and the error? try reindicating the selector

i would tell you to do an apprach with dinamically selectors.
that is:
using the explorer see all information that is related to that uicontrol. ( you can click on it and then you’ll see the control information)
you’ll see some attributes that you can use to do dynamically selectors. for exemple let’s say that you have a direct field like “Name” and a textbox to insert the name. if you explore that direct field you’ll see the id of that field. then click the textbox and try to view if there is a relation of those fields. then if you find that relation you cancreate a variable and fine tune the activity that is having problems… i had similar problems and i had overpass it with what i’ve describe to you.

Hi @fzhang ,

Have you tried other modes also.

Make sure Extension is enabled for browser

I think your selector exist in previous page.

Try to use delay after in previous activity (maybe is it a click?)and set waitforready COMPLETE in your click.