Cant recognize the new elements on the window after submitting info and moving to next step of the page

Hi,

I have a problem, i open a page with open browser fill adequate info and after that i press submit. Everything work to this point but when i then try to continue with recording it doesnt recognize the elements. Currently its done with attach browser. Should I do it in other way? Is there some wait time needed for loading of the new page? Im not sure and im losing hope.

Could you please help me?

What is the error/exception you see? Did you try to change your Selector for Attach browser?

Please see if you can attach a workflow or some more information, it is a bit hard to answer only from what you have described

Thanks,
Prankur

Thanks for the quick reply.

Change it to what? It does seem that it is not pointing to the right window but inside my selector is just

last working step is click on a submit button

after that loads a new page and anything I try to point on page shows me this error
Capture

The selector there doesn’t seem very robust, could you open this element in UiExplorer and see what options there are for you to select?

1 Like

This is what I get when I clikc on the topmost element of Internet Explorer site

but i get this error when I try to implement it
Error

Thanks for help

Is your click activity->properties->target->WaitForReady option in “complete”?

Again thanks for help

It was but I tried it with options as well now. It seems more like the robot doesn’t recognize the new page after submit and nothing on it, because it searches for elements the default 30 seconds and doesn’t find anything.

Can you share the attach browser and click activity selectors.

This is my attach browser selector

But i think i found where the problem is

the parent id number is randomly generated. There are three pieces of data that i need to get but each of them has different parentid each time. Do you know how could this be fixed?

give parentid=’*’

I tried but there are three instances from which i need to get information and if I give parentid=’*’ and try to copy data it just copies the first data three times

indicate using UiExplorer and check weather it is showing values like basic,comfort,exclusive or reliable assurance, the flexible tarriff with extra, extra payments

This is what I get when I click wit UI explorer directly on span

and this is what I get when I click on the whole box

I already tried to work with LA parent id but it doesnt work

please share the uiexplorer screen shot for all 3 basic,comfort and exclusive

These images are all from clicking on the whole box

check aaname also and use wild card for amount
Term life insuranceBasic*-CHF / YearReIiabIe assurance
Term life insuranceComfort*-CHF / YearThe flexible tariff with extras
Term life insuranceExclusive*-CHF/ YearExtra payments

It does not work, again this is the error im getting 1

The selectors look like this for the ones (and are done in similiar way for the other two)
2

and i tried to uncheck the parent id version as well

Thanks for all the help so far i really appreciate it

So I changed the parentid element on the site from always changing to static LA3_amount (LA2,LA1 for respective boxes) it did work twice when I have tested it but when I closed and opened the program its again not

4 5

Im really lost what could have changed? I mean the tags are not completely same but it cant find the element

I found a solution! Thank you for all your help and support :slight_smile: You are superb community

1 Like